aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 16:39:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 05:44:17 -0300
commitc831d06298db806426065d72305852a2a2d898ea (patch)
tree825b390fdf6617dc722209e8ada08ee813f4959e /unmaintained
parent68780134fd400678fcbaafa1f08f001451fa937b (diff)
downloadaports-c831d06298db806426065d72305852a2a2d898ea.tar.bz2
aports-c831d06298db806426065d72305852a2a2d898ea.tar.xz
unmaintained/py-pysqlite: move from community
Only exists to fulfill the lack of a sqlite3 library in the python2 standard library, unlike python3
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-pysqlite/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/py-pysqlite/APKBUILD b/unmaintained/py-pysqlite/APKBUILD
new file mode 100644
index 0000000000..73dc24efa2
--- /dev/null
+++ b/unmaintained/py-pysqlite/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+pkgname=py-pysqlite
+_pkgname=pysqlite
+pkgver=2.8.3
+pkgrel=1
+pkgdesc="Python DB-API 2.0 interface for the SQLite"
+url="https://pypi.python.org/pypi/pysqlite"
+arch="all"
+license="MIT"
+subpackages="py2-${pkgname/py-/}:_py2"
+makedepends="python2-dev py-setuptools sqlite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+sha512sums="9bf378b47fe020b378a9bd749b2b27cefcf8018fbe715cca54004b36092d2202ed0bb7d8fb8bc9820ce16918e01cea8bd1f032c640d1c461bd99cdf2632b8e3e pysqlite-2.8.3.tar.gz"