aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-04 11:48:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-04 13:23:04 +0000
commit301c970ef4e3c1c1371662a6bb39953c658d9cb1 (patch)
tree416430c0f557629f3f3af76314e32a3cc9aa1fda /unmaintained
parent3a329ef78935857e218db6e81db502df98759feb (diff)
downloadaports-301c970ef4e3c1c1371662a6bb39953c658d9cb1.tar.bz2
aports-301c970ef4e3c1c1371662a6bb39953c658d9cb1.tar.xz
unmaintained/xf86-video-mach64: unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/xf86-video-mach64/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/xf86-video-mach64/APKBUILD b/unmaintained/xf86-video-mach64/APKBUILD
new file mode 100644
index 0000000000..40c696e7ed
--- /dev/null
+++ b/unmaintained/xf86-video-mach64/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-mach64
+pkgver=6.9.5
+pkgrel=1
+pkgdesc="ATI Mach64 video driver"
+url="http://xorg.freedesktop.org/"
+arch=""
+license="custom"
+subpackages="$pkgname-doc"
+depends="mesa-dri-mach64"
+makedepends="xorg-server-dev libxi-dev fontsproto randrproto
+ videoproto renderproto xineramaproto libdrm-dev xf86driproto glproto
+ mesa-dev
+ "
+
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="1013ccc86052d0e82c4d504e0c4e896e xf86-video-mach64-6.9.5.tar.bz2"
+sha256sums="3e98985b6e044189efd42342862208f472881c25debf22230a1d54a96d71b41f xf86-video-mach64-6.9.5.tar.bz2"
+sha512sums="855b1a505c4309dd6accd0a2b371763fe98f510e0b6c680e2b2a1ce780e4ee6ea8eeeafb85fd22b879a25679b4c3f03a8216b2ea5797fbbc00fccd597fb7622d xf86-video-mach64-6.9.5.tar.bz2"