aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-11-26 17:12:36 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-27 15:33:15 +0100
commit9a458282e61fc4548fb28a3928beb148e09d5477 (patch)
tree4b5fc1b26cd3069fe3417133525deea75a3be1cb /unmaintained
parent2bf1ac9ad347711143892c14805605b60662da9b (diff)
downloadaports-9a458282e61fc4548fb28a3928beb148e09d5477.tar.bz2
aports-9a458282e61fc4548fb28a3928beb148e09d5477.tar.xz
unmaintained/dovecot-antispam-plugin: move from testing
This package has been deprecated by the developer- https://hg.dovecot.org/
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/dovecot-antispam-plugin/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/dovecot-antispam-plugin/APKBUILD b/unmaintained/dovecot-antispam-plugin/APKBUILD
new file mode 100644
index 0000000000..c053761754
--- /dev/null
+++ b/unmaintained/dovecot-antispam-plugin/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Kozak Ivan <kozak-iv@yandex.ru>
+# Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
+pkgname=dovecot-antispam-plugin
+pkgver=51
+pkgrel=2
+pkgdesc="Integrates DSPAM into dovecot IMAP server. Mercurial Version for dovecot >= 2.1"
+url="http://hg.dovecot.org/dovecot-antispam-plugin/"
+arch="all"
+license="GPL"
+depends="dovecot"
+depends_dev="dovecot-dev mercurial autoconf automake gawk"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source=""
+
+_hgroot="http://hg.dovecot.org/dovecot-antispam-plugin"
+_hgrepo="dovecot-antispam-plugin"
+_builddir="$srcdir/$_hgrepo"
+
+prepare() {
+ cd "$srcdir"
+ msg "Connecting to Mercurial server..."
+ if [ -d "$_hgrepo" ]; then
+ cd "$_hgrepo"
+ hg pull -r 51 -u
+ msg "The local files are updated."
+ else
+ hg clone -r 51 "$_hgroot" "$_hgrepo"
+ fi
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh || return 1
+ ./configure --prefix=/usr --with-dovecot=/usr/lib/dovecot || return 1
+ sed -i -e 's/install -o/install -D -o/' -e 's|$(INSTALLDIR)/|$(INSTALLDIR)/$(LIBRARY_NAME)|' Makefile || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+