aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-12-18 12:41:03 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2015-12-18 12:43:04 +0100
commita895e5181475460c78f7181063925467d8c88dca (patch)
tree90eb7c67213c14de346a1400d55ab38d7372dfab /unmaintained
parent44e371dc3f6dd83467da99f9d4f7667902fbdc12 (diff)
downloadaports-a895e5181475460c78f7181063925467d8c88dca.tar.bz2
aports-a895e5181475460c78f7181063925467d8c88dca.tar.xz
testing/texlive: move from unmaintained
This package is not even halfway decent. People constantly complain that it doesn't work as expected and sadly nobody is interested in maintaining it so I will move it to unmaintained for now.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/texlive/APKBUILD103
1 files changed, 103 insertions, 0 deletions
diff --git a/unmaintained/texlive/APKBUILD b/unmaintained/texlive/APKBUILD
new file mode 100644
index 0000000000..14a7ef2c6c
--- /dev/null
+++ b/unmaintained/texlive/APKBUILD
@@ -0,0 +1,103 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=texlive
+pkgver=20150521
+pkgrel=4
+pkgdesc="A complete TeX distribution"
+url="http://tug.org/texlive/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
+ cairo-dev pixman-dev zziplib-dev libpaper-dev graphite2-dev
+ libxmu-dev fontconfig-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.tug.org/historic/systems/$pkgname/${pkgver%????}/$pkgname-$pkgver-source.tar.xz"
+
+_builddir="$srcdir"/texlive-$pkgver-source
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir -p $_builddir/build && cd $_builddir/build
+ ../configure -C \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-epsfwin \
+ --enable-ipc \
+ --enable-luatex \
+ --enable-mftalkwin \
+ --enable-regiswin \
+ --enable-shared \
+ --enable-tektronixwin \
+ --enable-unitermwin \
+ --enable-xetex \
+ --disable-biber \
+ --disable-bibtex-x \
+ --disable-chktex \
+ --disable-cjkutils \
+ --disable-detex \
+ --disable-dialog \
+ --disable-dvi2tty \
+ --disable-dvipng \
+ --disable-dvipsk \
+ --disable-dvisvgm \
+ --disable-largefile \
+ --disable-lcdf-typetools \
+ --disable-multiplatform \
+ --disable-native-texlive-build \
+ --disable-pdfopen \
+ --disable-ps2eps \
+ --disable-ps2pkm \
+ --disable-psutils \
+ --disable-t1utils \
+ --disable-tex4htk \
+ --disable-ttf2pk2 \
+ --disable-vlna \
+ --disable-xdvik \
+ --disable-xindy \
+ --with-ps=gs \
+ --with-banner-add="/Alpine Linux" \
+ --with-system-cairo \
+ --with-system-freetype2 \
+ --with-system-graphite2 \
+ --with-system-harfbuzz \
+ --with-system-icu \
+ --with-system-icu \
+ --with-system-libpaper \
+ --with-system-libpng \
+ --with-system-pixman \
+ --with-system-poppler \
+ --with-system-xpdf \
+ --with-system-zlib \
+ --with-system-zziplib \
+ --without-texinfo \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+ cp -rf ../texk/tests/TeXLive \
+ "$pkgdir"/usr/share/texmf-dist/scripts/texlive || return 1
+}
+
+md5sums="e526bd57118c4c4d5e9d525d20b5ac02 texlive-20150521-source.tar.xz"
+sha256sums="ed9bcd7bdce899c3c27c16a8c5c3017c4f09e1d7fd097038351b72497e9d4669 texlive-20150521-source.tar.xz"
+sha512sums="9d06bb88c489715787ce619c4c6b5e2d4251e1db8d48ae7fe2d1a253634c76bc6d7282ef9c93c77847845cae01eafb58dfb37ba3fb83a6d223f0d7fe8f5d3855 texlive-20150521-source.tar.xz"