aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-01 10:30:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commitaa43f31f02bf427d74c3182677dd6ceb92053e5f (patch)
treea3b0a9158626b6f8167a9c336daddc1ddf007246 /unmaintained
parent60785abc20208c3ee6608c9b181e1e2ec8b3ccb5 (diff)
downloadaports-aa43f31f02bf427d74c3182677dd6ceb92053e5f.tar.bz2
aports-aa43f31f02bf427d74c3182677dd6ceb92053e5f.tar.xz
community/gst-plugins-bad0.10: move to unmaintained
does not build with openssl 1.1
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/gst-plugins-bad0.10/APKBUILD60
-rw-r--r--unmaintained/gst-plugins-bad0.10/libvpx-1.4.0.patch13
2 files changed, 73 insertions, 0 deletions
diff --git a/unmaintained/gst-plugins-bad0.10/APKBUILD b/unmaintained/gst-plugins-bad0.10/APKBUILD
new file mode 100644
index 0000000000..c84e7a301d
--- /dev/null
+++ b/unmaintained/gst-plugins-bad0.10/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad0.10
+pkgver=0.10.23
+pkgrel=9
+pkgdesc="GStreamer bad plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL GPL"
+depends=""
+replaces="gst-plugins-bad"
+subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
+makedepends="gst-plugins-base0.10-dev gstreamer0.10-dev xvidcore-dev bzip2-dev
+ neon-dev faac-dev libexif-dev faad2-dev glib-dev orc-dev
+ alsa-lib-dev libx11-dev sdl-dev libvpx-dev libdc1394-dev
+ libmms-dev gsm-dev flite-dev orc-dev jasper-dev librsvg-dev"
+
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.bz2
+ libvpx-1.4.0.patch
+ "
+
+_builddir="$srcdir/gst-plugins-bad-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-modplug \
+ --enable-experimental \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fcb09798114461955260e4d940db5987 gst-plugins-bad-0.10.23.tar.bz2
+3843843f65ce46970c08f90dfcd0003b libvpx-1.4.0.patch"
+sha256sums="0eae7d1a1357ae8377fded6a1b42e663887beabe0e6cc336e2ef9ada42e11491 gst-plugins-bad-0.10.23.tar.bz2
+6088e8935bf9873d75f229675560c7ef134186298074ebdff55b012a1b4056c9 libvpx-1.4.0.patch"
+sha512sums="da73c4dcfcfd5afe8414920d83b6b2d4634daacfca70653e850e9a7ec519275b9b1b76f46aa8b87c0c5dcd8696d5b05b7c54a0f66698725e7f726b81eb367ddb gst-plugins-bad-0.10.23.tar.bz2
+399e4996945a75fa6f1a440dd204b191f1a6386757c62a63c1bd020958d54978b3e97a5cff3d8154ce103b15c7798d6dadb2fd8e049bce7b429459aaa128be70 libvpx-1.4.0.patch"
diff --git a/unmaintained/gst-plugins-bad0.10/libvpx-1.4.0.patch b/unmaintained/gst-plugins-bad0.10/libvpx-1.4.0.patch
new file mode 100644
index 0000000000..fc4c94098e
--- /dev/null
+++ b/unmaintained/gst-plugins-bad0.10/libvpx-1.4.0.patch
@@ -0,0 +1,13 @@
+--- ./ext/vp8/gstvp8utils.h.orig
++++ ./ext/vp8/gstvp8utils.h
+@@ -26,10 +26,6 @@
+ G_BEGIN_DECLS
+
+ /* Some compatibility defines for older libvpx versions */
+-#ifndef VPX_IMG_FMT_I420
+-#define VPX_IMG_FMT_I420 IMG_FMT_I420
+-#endif
+-
+ #ifndef VPX_PLANE_Y
+ #define VPX_PLANE_Y PLANE_Y
+ #endif