aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-03 14:29:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-03 14:29:40 +0000
commitae8b92c95dff49692f350f9b8e79bde854dd61b6 (patch)
tree5b37448fe097393797a9991787a92013aed87cbe /unmaintained
parent473c070d5ba6ed3c8f3badaa8968b6a98bf85f14 (diff)
downloadaports-ae8b92c95dff49692f350f9b8e79bde854dd61b6.tar.bz2
aports-ae8b92c95dff49692f350f9b8e79bde854dd61b6.tar.xz
unmaintained/owncloud: no longer maintained in favor of Nextcloud
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/owncloud/APKBUILD275
-rw-r--r--unmaintained/owncloud/fpm-pool.conf183
-rw-r--r--unmaintained/owncloud/owncloud-initscript.post-install22
-rw-r--r--unmaintained/owncloud/owncloud-initscript.pre-install6
-rw-r--r--unmaintained/owncloud/owncloud.confd5
-rw-r--r--unmaintained/owncloud/owncloud.config.php.in25
6 files changed, 516 insertions, 0 deletions
diff --git a/unmaintained/owncloud/APKBUILD b/unmaintained/owncloud/APKBUILD
new file mode 100644
index 0000000000..fe58310a68
--- /dev/null
+++ b/unmaintained/owncloud/APKBUILD
@@ -0,0 +1,275 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Maintainer:
+pkgname=owncloud
+pkgver=9.1.3
+pkgrel=0
+_contactsver="0.0.0.183"
+_calendarver="1.3.3"
+_tasksver="0.9.3"
+_documentsver="$pkgver"
+_pdfviewerver="$pkgver"
+_texteditorver="$pkgver"
+_musicver="0.3.11"
+_php=php5
+pkgdesc="Your own WebDAV-based cloud service"
+url="http://owncloud.org"
+arch="noarch"
+license="AGPL"
+depends="$_php ${_php}-ctype ${_php}-curl ${_php}-dom ${_php}-gd ${_php}-iconv
+ ${_php}-json ${_php}-xml ${_php}-xmlreader ${_php}-zlib ${_php}-zip"
+makedepends=""
+subpackages="$pkgname-initscript $pkgname-doc $pkgname-pgsql $pkgname-sqlite
+ $pkgname-mysql $pkgname-encryption $pkgname-calendar $pkgname-contacts
+ $pkgname-documents $pkgname-external $pkgname-gallery $pkgname-music
+ $pkgname-ldap $pkgname-tasks $pkgname-texteditor $pkgname-pdfviewer
+ $pkgname-videoplayer"
+replaces="$pkgname-plugins"
+source="https://download.owncloud.org/community/$pkgname-$pkgver.tar.bz2
+ $pkgname-contacts-$_contactsver.tar.gz::https://github.com/owncloud/contacts/releases/download/v$_contactsver/contacts.tar.gz
+ $pkgname-calendar-$_calendarver.tar.gz::https://github.com/owncloud/calendar/releases/download/v$_calendarver/calendar.tar.gz
+ $pkgname-documents-$_documentsver.tar.gz::https://github.com/owncloud/documents/archive/v$_documentsver.tar.gz
+ $pkgname-texteditor-$_texteditorver.tar.gz::https://github.com/owncloud/files_texteditor/archive/v$_texteditorver.tar.gz
+ $pkgname-music-$_musicver.zip::https://github.com/owncloud/music/releases/download/v$_musicver/music.zip
+ $pkgname-pdfviewer-$_pdfviewerver.tar.gz::https://github.com/owncloud/files_pdfviewer/archive/v$_pdfviewerver.tar.gz
+ $pkgname-tasks-$_tasksver.tar.gz::https://github.com/owncloud/tasks/archive/v$_tasksver.tar.gz
+ $pkgname.confd
+ fpm-pool.conf
+ owncloud.config.php.in
+ "
+pkgusers="owncloud"
+pkggroups="www-data"
+builddir="$srcdir/$pkgname"
+
+_ocbasedir="/var/lib/owncloud"
+_ocdatadir="$_ocbasedir/data"
+_ocwwwdir="/usr/share/webapps/owncloud"
+_ocappsdir="$_ocwwwdir/apps"
+_occonfdir="/etc/owncloud"
+
+prepare() {
+ default_prepare || return 1
+
+ sed "s/__VERSION__/$pkgver/" "$srcdir"/owncloud.config.php.in \
+ > "$srcdir"/owncloud.config.php
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"$_occonfdir "$pkgdir"$_ocdatadir "$pkgdir"$_ocwwwdir
+
+ rm -rf config data
+ mv * "$pkgdir"${_ocwwwdir}/ || return 1
+ chmod +x "$pkgdir"${_ocwwwdir}/occ || return 1
+
+ ln -s $_occonfdir "$pkgdir"${_ocwwwdir}/config || return 1
+ install -m660 ../owncloud.config.php \
+ "$pkgdir"${_occonfdir}/config.php || return 1
+ install -m664 .htaccess "$pkgdir"${_ocwwwdir}/.htaccess || return 1
+
+ local dir; for dir in $_occonfdir $_ocdatadir $_ocappsdir; do
+ chown -R :www-data "$pkgdir"$dir || return 1
+ chmod 770 "$pkgdir"$dir || return 1
+ done
+}
+
+initscript() {
+ pkgdesc="Init script that runs ownCloud with php-fpm"
+ depends="$pkgname $_php-fpm"
+ install="$subpkgname.pre-install $subpkgname.post-install"
+
+ local confdir="$subpkgdir/etc/$_php/php-fpm.d"
+ local fpm_name="php-fpm${_php:3}"
+
+ if [ "$_php" = "php5" ]; then
+ confdir="${confdir/php-/}"
+ fpm_name="php-fpm"
+ fi
+
+ install -m 755 -o owncloud -d "$subpkgdir"/var/log/$pkgname || return 1
+ install -m 700 -o owncloud -d "$subpkgdir"/var/tmp/$pkgname || return 1
+
+ install -m 644 -D "$srcdir"/fpm-pool.conf \
+ "$confdir"/$pkgname.conf || return 1
+
+ install -m 644 -D "$srcdir"/$pkgname.confd \
+ "$subpkgdir"/etc/conf.d/$pkgname || return 1
+
+ mkdir -p "$subpkgdir"/etc/init.d
+ ln -s $fpm_name "$subpkgdir"/etc/init.d/$pkgname
+}
+
+doc() {
+ pkgdesc="$pkgdesc (documentation)"
+ depends="$pkgname"
+
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/core
+ mv "$pkgdir"/usr/share/webapps/$pkgname/core/doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/core
+}
+
+pgsql() {
+ pkgdesc="ownCloud PostgreSQL support"
+ depends="$pkgname ${_php}-pgsql ${_php}-pdo_pgsql ${_php}-pear-mdb2-driver-pgsql"
+
+ mkdir -p "$subpkgdir"
+}
+
+sqlite() {
+ pkgdesc="ownCloud SQLite support"
+ depends="$pkgname ${_php}-sqlite3 ${_php}-pdo_sqlite"
+
+ mkdir -p "$subpkgdir"
+}
+
+mysql() {
+ pkgdesc="ownCloud MySQL support"
+ depends="$pkgname ${_php}-mysql ${_php}-pdo_mysql ${_php}-pear-mdb2-driver-mysql"
+
+ mkdir -p "$subpkgdir"
+}
+
+plugins() {
+ pkgdesc="ownCloud 3rdparty plugins"
+ depends="$pkgname"
+
+ mkdir -p "$subpkgdir"${_ocwwwdir}
+ mv "$pkgdir"${_ocwwwdir}/3rdparty "$subpkgdir"${_ocwwwdir}/
+}
+
+_mv_app() {
+ local from="$1"
+ local dir="$2"
+
+ mkdir -p "$subpkgdir"${_ocappsdir}
+
+ if [ "$from" = "pkg" ]; then
+ mv "$pkgdir"${_ocappsdir}/$dir "$subpkgdir"${_ocappsdir}/ || return 1
+ elif [ "$from" = "src" ]; then
+ local appname="${subpkgname#$pkgname-}"
+ mv "$srcdir"/$dir "$subpkgdir"${_ocappsdir}/$appname/ || return 1
+ fi
+ chown -R :www-data "$subpkgdir"${_ocappsdir} || return 1
+ chmod 770 "$subpkgdir"${_ocappsdir} || return 1
+}
+
+contacts() {
+ pkgdesc="ownCloud contacts"
+ depends="$pkgname"
+
+ _mv_app src contacts
+}
+
+calendar() {
+ pkgdesc="ownCloud calendar"
+ depends="$pkgname"
+
+ _mv_app src calendar
+}
+
+documents() {
+ pkgdesc="ownCloud integrated documents editor"
+ depends="$pkgname"
+
+ _mv_app src documents-$_documentsver
+}
+
+encryption() {
+ pkgdesc="ownCloud integrated encryption support"
+ depends="$pkgname ${_php}-openssl"
+
+ _mv_app pkg encryption
+}
+
+external() {
+ pkgdesc="ownCloud integrated external storage support"
+ depends="$pkgname ${_php}-curl ${_php}-ftp"
+
+ _mv_app pkg files_external
+}
+
+gallery() {
+ pkgdesc="ownCloud integrated gallery application"
+ depends="$pkgname"
+
+ _mv_app pkg gallery
+}
+
+ldap() {
+ pkgdesc="ownCloud integrated LDAP authentication"
+ depends="$pkgname ${_php}-ldap"
+
+ _mv_app pkg user_ldap
+}
+
+music() {
+ pkgdesc="ownCloud music app"
+ depends="$pkgname"
+
+ _mv_app src music
+ # Correct world-writable directories.
+ find "${subpkgdir}${_ocappsdir}" -type d -exec chmod 775 {} \;
+}
+
+pdfviewer() {
+ pkgdesc="ownCloud integrated PDF viewer"
+ depends="$pkgname"
+
+ _mv_app pkg files_pdfviewer
+}
+
+tasks() {
+ pkgdesc="ownCloud tasks"
+ depends="$pkgname"
+
+ _mv_app src tasks-$_tasksver
+}
+
+texteditor() {
+ pkgdesc="ownCloud integrated text editor"
+ depends="$pkgname"
+
+ _mv_app pkg files_texteditor
+}
+
+videoplayer() {
+ pkgdesc="ownCloud integrated video viewer"
+ depends="$pkgname"
+ provides="$pkgname-videoviewer"
+
+ _mv_app pkg files_videoplayer
+}
+
+md5sums="095df252495e246a053fee7c048db255 owncloud-9.1.3.tar.bz2
+a2623501e3e524b973759a9628a4749d owncloud-contacts-0.0.0.183.tar.gz
+1183d4bb6a1ef40b10473757e4694c52 owncloud-calendar-1.3.3.tar.gz
+4f7058773d488c022cdc3735d6e293d0 owncloud-documents-9.1.3.tar.gz
+cc694da1f081181a9e36194803e50b3d owncloud-texteditor-9.1.3.tar.gz
+8452cdd43587469e680597a2c10c830e owncloud-music-0.3.11.zip
+3420df7f6c05ca20be239ea5cebfd7a4 owncloud-pdfviewer-9.1.3.tar.gz
+84e7e522faa5f4a6bd3c75a29e259bcb owncloud-tasks-0.9.3.tar.gz
+ea483e710da2fa9995543d9b5b8ee11e owncloud.confd
+779c544fd1900557f4e69504aa28eeed fpm-pool.conf
+e1081190b2916a7f61fe403a03d8fa06 owncloud.config.php.in"
+sha256sums="e0a1eb35fffb61dab5ca41f6d3fdb4ddcc3ec09683cd620b8094846785d4f6e9 owncloud-9.1.3.tar.bz2
+d6ea14796f27f4cfb6db63b8e3612a71d3e3e6e2d8edffce85df45fcb71c7106 owncloud-contacts-0.0.0.183.tar.gz
+e3cd0de34e7de1d9f08d5c7dce5e9f45826cc9e59292b847fa900ca3cdf6b3fc owncloud-calendar-1.3.3.tar.gz
+7028152d65d463791353f256f39f85d131b6b7481d266ec16354ab55d7d8444f owncloud-documents-9.1.3.tar.gz
+888b6c803240415d04de064c3768740b650709a971854222e8638644ea2e138e owncloud-texteditor-9.1.3.tar.gz
+e480e639e48419977f06822aa92f1245c21a43d9aafc156edb6fd097873a73ca owncloud-music-0.3.11.zip
+db3f803990612b1e6c6500a0b77ef7383da318b5b6e61bd4a1a4e586dc9b192f owncloud-pdfviewer-9.1.3.tar.gz
+0a5ef52ba915e7ec8f124ab7bd2c01f22db27f77343ddfa8d799927711133c55 owncloud-tasks-0.9.3.tar.gz
+96d61ee75e8c948f78d31bdb770636819b8d678892a4003168c140fab69861cd owncloud.confd
+41dd626e34ea0b0ea3eac13b43a655586097fe746d5a713c0c765dbc2b8c2fa0 fpm-pool.conf
+d00bdbf610d6994cdb61269620dc0fdb892a43a10895c00060d72731f7acd854 owncloud.config.php.in"
+sha512sums="e661d3a69d1bce51aa6336fddd2ba205970d0d14e306a6ea0befa9fad6bb3563ff26118cd0471d4728cd9387fe67b58ba55058109bbf84f6c5c71fd87be38cea owncloud-9.1.3.tar.bz2
+7d0b3808a8734cd6895847ea1986345df71cd7e0633dcf2b8b9989bc9d38c3182bf6d93d75c32378270d124e885d7d730fd1ead5198bd9276de8425a5ff725d3 owncloud-contacts-0.0.0.183.tar.gz
+8f2b260a63644a5fb529211dd160aa3169ffde56ceeacf25f7c7748b2d7dfa9b1115663955eae3b9e35283545e57ff1b6f48ea75713f50db6bab51ebdb5e598e owncloud-calendar-1.3.3.tar.gz
+9494672aeb6a4cf193c2b5f258a781713c009c47060f17ed951aa7cd9d3d00d912983156aa30d2d2b27667d30f746e496053e63a495e1e36f9072fa153745e96 owncloud-documents-9.1.3.tar.gz
+df0425e2769f32f7b8919e67e7eece3a9fd2d7a86a1fe1875a31ab1e3d0829a7b178ee2c6bc9a4ca13777f27c1f880792d6f8638fb72c0fd6c53312af0cc8f7d owncloud-texteditor-9.1.3.tar.gz
+fde1758a512a960985cbbfde9294f77458fad2cb4801daceedac76a58dbb2862f2586cb17376915cdcb47a768c75be46f863834a96f1148eae98285217491d59 owncloud-music-0.3.11.zip
+9b3642ba9a1b01dbcc96c4e46735a546c6e0bdb77f87b166aadf9dc1c0c27a276bf4464009d9ef494107786c1ab38f59d218e0f9a2aa2a9a3db2e1e002fbebbe owncloud-pdfviewer-9.1.3.tar.gz
+05903caadaab8c7982cb91b1442d617c777a9d97fcd5406d1b404006fa91ef73251852a53a03cb7fcbed097c1120fc920983c1a24a0e8f1f2e95b230153fd26a owncloud-tasks-0.9.3.tar.gz
+7d1fa12f08f74b88d1ba7858a8295f6e5b200f16ed7366af48cc891b8c0074da85df008ed6f920df8b61bdfd5a27ac2a9623309b6334f82051a04067e746023e owncloud.confd
+e5afd329faf06acec747cb2af8dea409b6991dcc7aa15e894444899ccaf17502fdfab437cfb91170d1e1aee39385b72f277922dccdd8c6e08cc928b146ccaeda fpm-pool.conf
+c7aa08cf9b8fb8f61454af3ccc5b743e33b4cc294e6c42ed2eb16894f0a411b22bdc4d8f691964860a7c88ea7255424c1e369063ae37041850a9624b4139d478 owncloud.config.php.in"
diff --git a/unmaintained/owncloud/fpm-pool.conf b/unmaintained/owncloud/fpm-pool.conf
new file mode 100644
index 0000000000..57db4968c2
--- /dev/null
+++ b/unmaintained/owncloud/fpm-pool.conf
@@ -0,0 +1,183 @@
+[global]
+; Error log file
+; Default Value: log/php-fpm.log
+error_log = /var/log/owncloud/php-fpm.log
+
+; Log level
+; Possible Values: alert, error, warning, notice, debug
+; Default Value: notice
+log_level = warning
+
+; If this number of child processes exit with SIGSEGV or SIGBUS within the time
+; interval set by emergency_restart_interval then FPM will restart. A value
+; of '0' means 'Off'.
+; Default Value: 0
+emergency_restart_threshold = 10
+
+; Interval of time used by emergency_restart_interval to determine when
+; a graceful restart will be initiated. This can be useful to work around
+; accidental corruptions in an accelerator's shared memory.
+; Available Units: s(econds), m(inutes), h(ours), or d(ays)
+; Default Unit: seconds
+; Default Value: 0
+emergency_restart_interval = 1m
+
+; Time limit for child processes to wait for a reaction on signals from master.
+; Available units: s(econds), m(inutes), h(ours), or d(ays)
+; Default Unit: seconds
+; Default Value: 0
+process_control_timeout = 10s
+
+
+[owncloud]
+; The address on which to accept FastCGI requests.
+; Valid syntaxes are:
+; 'ip.add.re.ss:port' - to listen on a TCP socket to a specific address on
+; a specific port;
+; 'port' - to listen on a TCP socket to all addresses on a
+; specific port;
+; '/path/to/unix/socket' - to listen on a unix socket (the path is *not*
+; relative to chroot!)
+; Note: This value is mandatory.
+listen = /run/owncloud/fastcgi.sock
+
+; Set permissions for unix socket, if one is used. In Linux, read/write
+; permissions must be set in order to allow connections from a web server. Many
+; BSD-derived systems allow connections regardless of permissions.
+; Default Values: user and group are set as the running user
+; mode is set to 0666
+listen.mode = 0660
+
+; Choose how the process manager will control the number of child processes.
+; Possible Values:
+; static ... a fixed number of child processes.
+; dynamic ... the number of child processes are set dynamically.
+; ondemand ... no children are created at startup; children will be forked
+; when new requests will connect.
+; Note: This value is mandatory.
+pm = ondemand
+
+; The number of child processes to be created when pm is set to 'static' and the
+; maximum number of child processes when pm is set to 'dynamic' or 'ondemand'.
+; This value sets the limit on the number of simultaneous requests that will be
+; served.
+; Note: Used when pm is set to 'static', 'dynamic' or 'ondemand'
+; Note: This value is mandatory.
+pm.max_children = 15
+
+; The number of seconds after which an idle process will be killed.
+; Note: Used only when pm is set to 'ondemand'
+; Default Value: 10s
+pm.process_idle_timeout = 120s
+
+; The number of requests each child process should execute before respawning.
+; This can be useful to work around memory leaks in 3rd party libraries. For
+; endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS.
+; Default Value: 0
+pm.max_requests = 500
+
+; The URI to view the FPM status page. If this value is not set, no URI will be
+; recognized as a status page.
+; Note: The value must start with a leading slash (/). The value can be
+; anything, but it may not be a good idea to use the .php extension or it
+; may conflict with a real PHP file.
+; Default Value: not set
+pm.status_path =
+
+; The ping URI to call the monitoring page of FPM. If this value is not set, no
+; URI will be recognized as a ping page. This could be used to test from outside
+; that FPM is alive and responding, or to
+; - create a graph of FPM availability (rrd or such);
+; - remove a server from a group if it is not responding (load balancing);
+; - trigger alerts for the operating team (24/7).
+; Note: The value must start with a leading slash (/). The value can be
+; anything, but it may not be a good idea to use the .php extension or it
+; may conflict with a real PHP file.
+; Default Value: not set
+ping.path = /ping
+
+; The timeout for serving a single request after which the worker process will
+; be killed. This option should be used when the 'max_execution_time' ini option
+; does not stop script execution for some reason. A value of '0' means 'off'.
+; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
+; Default Value: 0
+;request_terminate_timeout = 0
+
+; The timeout for serving a single request after which a PHP backtrace will be
+; dumped to the 'slowlog' file. A value of '0s' means 'off'.
+; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
+; Default Value: 0
+;request_slowlog_timeout = 0
+
+; The log file for slow requests
+; Default Value: not set
+; Note: slowlog is mandatory if request_slowlog_timeout is set
+; Note: the path is *not* relative to chroot.
+;slowlog = /var/log/owncloud/php-fpm.slow.log
+
+; Redirect worker stdout and stderr into main error log. If not set, stdout and
+; stderr will be redirected to /dev/null according to FastCGI specs.
+; Note: on highloaded environement, this can cause some delay in the page
+; process time (several ms).
+; Default Value: no
+;catch_workers_output = yes
+
+; Pass environment variables like LD_LIBRARY_PATH. All $VARIABLEs are taken from
+; the current environment.
+; Default Value: clean env
+env[PATH] = /usr/bin:/bin
+
+; Additional php.ini defines, specific to this pool of workers. These settings
+; overwrite the values previously defined in the php.ini. The directives are the
+; same as the PHP SAPI:
+; php_value/php_flag - you can set classic ini defines which can
+; be overwritten from PHP call 'ini_set'.
+; php_admin_value/php_admin_flag - these directives won't be overwritten by
+; PHP call 'ini_set'
+; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no.
+;
+; Defining 'extension' will load the corresponding shared extension from
+; extension_dir. Defining 'disable_functions' or 'disable_classes' will not
+; overwrite previously defined php.ini values, but will append the new value
+; instead.
+;
+; Note: path INI options can be relative and will be expanded with the prefix
+; (pool, global or /usr/lib/php5.3)
+
+; Allow HTTP file uploads.
+php_admin_flag[file_uploads] = true
+
+; Maximal size of a file that can be uploaded via web interface.
+php_admin_value[memory_limit] = 512M
+php_admin_value[post_max_size] = 513M
+php_admin_value[upload_max_filesize] = 513M
+
+; Where to store temporary files.
+php_admin_value[session.save_path] = /var/tmp/owncloud
+php_admin_value[sys_temp_dir] = /var/tmp/owncloud
+php_admin_value[upload_tmp_dir] = /var/tmp/owncloud
+
+; Log errors to specified file.
+php_admin_value[error_log] = /var/log/owncloud/php.error.log
+
+; OPcache error_log file name. Empty string assumes "stderr"
+php_admin_value[opcache.error_log] = /var/log/owncloud/php.error.log
+
+; Output buffering is a mechanism for controlling how much output data
+; (excluding headers and cookies) PHP should keep internally before pushing that
+; data to the client. If your application's output exceeds this setting, PHP
+; will send that data in chunks of roughly the size you specify.
+; This must be disabled for ownCloud.
+php_admin_flag[output_buffering] = false
+
+; Overload(replace) single byte functions by mbstring functions.
+; This must be disabled for ownCloud.
+php_admin_flag[mbstring.func_overload] = false
+
+; Never populate the $HTTP_RAW_POST_DATA variable.
+; http://php.net/always-populate-raw-post-data
+php_admin_value[always_populate_raw_post_data] = -1
+
+; Disable certain functions for security reasons.
+; http://php.net/disable-functions
+php_admin_value[disable_functions] = exec,passthru,shell_exec,system,proc_open,curl_multi_exec,show_source
diff --git a/unmaintained/owncloud/owncloud-initscript.post-install b/unmaintained/owncloud/owncloud-initscript.post-install
new file mode 100644
index 0000000000..92db889626
--- /dev/null
+++ b/unmaintained/owncloud/owncloud-initscript.post-install
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+# It's not needed to be writable for www-data group when running with php-fpm.
+for dir in /etc/owncloud \
+ /etc/owncloud/config.php \
+ /var/lib/owncloud/data \
+ /usr/share/webapps/owncloud/apps
+do
+ chmod g-w $dir
+ chown owncloud $dir
+done
+chgrp root /etc/owncloud/config.php
+
+cat <<EOF
+*
+* Point your web server to /run/owncloud/fastcgi.sock and start ownCloud with
+* /etc/init.d/owncloud start. You can modify php-fpm settings in
+* /etc/php5/fpm.d/owncloud.conf.
+*
+EOF
+
+exit 0
diff --git a/unmaintained/owncloud/owncloud-initscript.pre-install b/unmaintained/owncloud/owncloud-initscript.pre-install
new file mode 100644
index 0000000000..e162bbac1d
--- /dev/null
+++ b/unmaintained/owncloud/owncloud-initscript.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S -g 82 www-data 2>/dev/null
+adduser -S -D -H -h /var/lib/owncloud -s /sbin/nologin -G www-data -g ownCloud owncloud 2>/dev/null
+
+exit 0
diff --git a/unmaintained/owncloud/owncloud.confd b/unmaintained/owncloud/owncloud.confd
new file mode 100644
index 0000000000..c4bd6b162f
--- /dev/null
+++ b/unmaintained/owncloud/owncloud.confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/owncloud
+
+name="ownCloud"
+user="owncloud"
+group="www-data"
diff --git a/unmaintained/owncloud/owncloud.config.php.in b/unmaintained/owncloud/owncloud.config.php.in
new file mode 100644
index 0000000000..5fd814268c
--- /dev/null
+++ b/unmaintained/owncloud/owncloud.config.php.in
@@ -0,0 +1,25 @@
+<?php
+$CONFIG = array(
+ 'datadirectory' => '/var/lib/owncloud/data',
+ 'apps_path' => array (
+ 0 => array (
+ "path" => OC::$SERVERROOT."/apps",
+ "url" => "/apps",
+ "writable" => false,
+ ),
+ /* Uncomment this and install your apps here
+ 1 => array (
+ "path" => "/var/www/localhost/htdocs/myoc_apps",
+ "url" => "/myoc_apps",
+ "writable" = true,
+ ),
+ */
+ ),
+ 'version' => '__VERSION__',
+ 'dbname' => 'owncloud',
+ 'dbhost' => 'localhost',
+ 'dbuser' => 'owncloud',
+ 'installed' => false,
+ 'loglevel' => '0',
+);
+?>