aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-12 18:59:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-12 18:59:46 +0000
commitb6034b5bf15bb18ce77c685d3d6fe9b3915d43d9 (patch)
tree83d73cba6f766a2da3f2c78e61244b309ab471e3 /unmaintained
parent4a7de6def0502e9912cae6104039812ae2b6806c (diff)
downloadaports-b6034b5bf15bb18ce77c685d3d6fe9b3915d43d9.tar.bz2
aports-b6034b5bf15bb18ce77c685d3d6fe9b3915d43d9.tar.xz
testing/gnome-session: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/gnome-session/APKBUILD42
-rw-r--r--unmaintained/gnome-session/fail-whale-dialog.patch35
-rw-r--r--unmaintained/gnome-session/no-rpmatch.patch15
3 files changed, 92 insertions, 0 deletions
diff --git a/unmaintained/gnome-session/APKBUILD b/unmaintained/gnome-session/APKBUILD
new file mode 100644
index 0000000000..d62e739147
--- /dev/null
+++ b/unmaintained/gnome-session/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnome-session
+pkgver=3.26.0
+pkgrel=1
+pkgdesc="GNOME session manager"
+url="https://www.gnome.org/"
+arch="all !aarch64 !armhf !armv7 !s390x"
+license="GPL"
+depends="gnome-shell"
+makedepends="gnome-settings-daemon-dev libsm-dev
+ consolekit2-dev itstool libxslt libxml2-utils json-glib-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ no-rpmatch.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-systemd \
+ --enable-consolekit
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="05ba2465dee4b23d4cf758c15b7a682207fbc50039d95a60c37051cfa31707dc6737bcbf809812b429cb7ce03bf340d30e66916a579677586b3e531c862a6819 gnome-session-3.26.0.tar.xz
+0d6057cc47f3494050cf02f55b887ae0fea2b405fe3585b412f91c79dafaab77a4d3da2d77fa65bd43a7a9a77b83c11e78f68af659378f3f62f857ca1a86c6de no-rpmatch.patch"
diff --git a/unmaintained/gnome-session/fail-whale-dialog.patch b/unmaintained/gnome-session/fail-whale-dialog.patch
new file mode 100644
index 0000000000..e7a54f57f0
--- /dev/null
+++ b/unmaintained/gnome-session/fail-whale-dialog.patch
@@ -0,0 +1,35 @@
+$OpenBSD: patch-gnome-session_gsm-fail-whale-dialog_c,v 1.1 2017/05/30 18:14:03 ajacoutot Exp $
+
+https://bugzilla.gnome.org/show_bug.cgi?id=775463
+
+Index: gnome-session/gsm-fail-whale-dialog.c
+--- a/gnome-session/gsm-fail-whale-dialog.c.orig
++++ b/gnome-session/gsm-fail-whale-dialog.c
+@@ -371,13 +371,20 @@ int main (int argc, char *argv[])
+ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
+ textdomain (GETTEXT_PACKAGE);
+
+- gtk_init_with_args (&argc, &argv, " - fail whale",
+- entries, GETTEXT_PACKAGE,
+- &error);
+- if (error != NULL) {
+- g_warning ("%s", error->message);
+- exit (1);
+- }
++ if (!gtk_init_with_args (&argc, &argv, " - fail whale",
++ entries, GETTEXT_PACKAGE,
++ &error)) {
++ if (error != NULL) {
++ g_warning ("%s", error->message);
++ exit (1);
++ }
++
++ /* display server probably went away. Could be for legitimate reasons, could be for
++ * unexpected reasons. If it went away unexpectantly, that's logged elsewhere, so
++ * let's not add noise by logging here.
++ */
++ return 0;
++ }
+
+ fail_dialog = g_object_new (GSM_TYPE_FAIL_WHALE_DIALOG, NULL);
+ fail_dialog->priv->debug_mode = debug_mode;
diff --git a/unmaintained/gnome-session/no-rpmatch.patch b/unmaintained/gnome-session/no-rpmatch.patch
new file mode 100644
index 0000000000..ea41bf46e5
--- /dev/null
+++ b/unmaintained/gnome-session/no-rpmatch.patch
@@ -0,0 +1,15 @@
+$OpenBSD: patch-gnome-session_main_c,v 1.19 2017/04/17 10:51:02 ajacoutot Exp $
+
+XXX no rpmatch(3) on OpenBSD
+
+--- a/gnome-session/main.c.orig Wed Apr 12 16:35:48 2017
++++ b/gnome-session/main.c Mon Apr 17 12:40:35 2017
+@@ -311,7 +311,7 @@ main (int argc, char **argv)
+
+ debug_string = g_getenv ("GNOME_SESSION_DEBUG");
+ if (debug_string != NULL) {
+- debug = rpmatch (debug_string) == TRUE || atoi (debug_string) == 1;
++ debug = atoi (debug_string) == 1;
+ }
+
+ error = NULL;