aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-10-20 07:49:25 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-10-20 07:49:25 +0000
commitd06bbe1abf6dd6c3b3ab43638fee2f3a347eb396 (patch)
treecaca4ab14404e64b98f70475243f4315b45920ce /unmaintained
parent78bf7d586ae1c538a20e13ac7cf97aee8047838e (diff)
downloadaports-d06bbe1abf6dd6c3b3ab43638fee2f3a347eb396.tar.bz2
aports-d06bbe1abf6dd6c3b3ab43638fee2f3a347eb396.tar.xz
testing/nemo: move to unmaintained
it depends on cinnamon-desktop which is unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/nemo/APKBUILD58
-rw-r--r--unmaintained/nemo/nemo.post-deinstall6
-rw-r--r--unmaintained/nemo/nemo.post-install6
-rw-r--r--unmaintained/nemo/nemo.post-upgrade6
-rw-r--r--unmaintained/nemo/stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch24
5 files changed, 100 insertions, 0 deletions
diff --git a/unmaintained/nemo/APKBUILD b/unmaintained/nemo/APKBUILD
new file mode 100644
index 0000000000..41b022486e
--- /dev/null
+++ b/unmaintained/nemo/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=nemo
+pkgver=2.0.8
+pkgrel=1
+pkgdesc="Cinnamon file manager (Nautilus fork)"
+url="https://github.com/linuxmint/nemo"
+arch="all"
+license="GPL"
+depends="gnome-icon-theme"
+depends_dev="glib-dev gtk+3.0-dev gobject-introspection-dev dconf-dev libexif-dev
+ cinnamon-desktop-dev libnotify-dev"
+makedepends="$depends_dev autoconf automake libtool gnome-common intltool gtk-doc"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/linuxmint/nemo/tarball/$pkgver
+ stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch"
+
+_builddir="$srcdir/linuxmint-nemo-562e147"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-update-mimedb \
+ --disable-schemas-compile \
+ --disable-gtk-doc-html \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2e1b4900c37fa36a95f0c2373171b5a4 nemo-2.0.8.tar.gz
+f8e90e6ea69e5cfff17e0557c9300d02 stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch"
+sha256sums="6a40868e46fd2ed6c27e694e76c160996d16e2d27681bf5126e6b0e647c24033 nemo-2.0.8.tar.gz
+9a30dc0168fd5fbd9c3d9a64924f505f6a3ec02b1a7853b28920b6e96bc575b1 stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch"
+sha512sums="75a3fee5d7f65cee3aa5961de6b9983c04d58d22943529bbfe08187e9c61cb4d3b39ceb2f76ba488c690836ddd10f7af66b02856de652d220dd525197c1753d8 nemo-2.0.8.tar.gz
+3fd37210ac2516320ac525c7e9a708ecfe3f1c9da23fed4c85dd15aa706d768c44153689351d69b578a40090d39ac4b19c6fdb609bc4020266ed290d5d0473bc stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch"
diff --git a/unmaintained/nemo/nemo.post-deinstall b/unmaintained/nemo/nemo.post-deinstall
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/unmaintained/nemo/nemo.post-deinstall
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/unmaintained/nemo/nemo.post-install b/unmaintained/nemo/nemo.post-install
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/unmaintained/nemo/nemo.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/unmaintained/nemo/nemo.post-upgrade b/unmaintained/nemo/nemo.post-upgrade
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/unmaintained/nemo/nemo.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/unmaintained/nemo/stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch b/unmaintained/nemo/stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch
new file mode 100644
index 0000000000..f093d96560
--- /dev/null
+++ b/unmaintained/nemo/stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch
@@ -0,0 +1,24 @@
+From ec95b5461c3e88e96e1049ef2650a28d347c13ba Mon Sep 17 00:00:00 2001
+From: leigh123linux <leigh123linux@fedoraproject.org>
+Date: Sat, 2 Nov 2013 22:29:35 +0000
+Subject: [PATCH] Stop GTK_STOCK deprecated errors for gtk-3.10
+
+---
+ configure.in | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index 0e7498e..557b6c6 100644
+--- a/configure.in
++++ b/configure.in
+@@ -296,7 +296,6 @@ PKG_CHECK_MODULES(NEMO, [
+ AC_SUBST(NEMO_CFLAGS)
+ AC_SUBST(NEMO_LIBS)
+
+-DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"
+ AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
+
+ dnl Multimedia keys
+--
+1.8.5.1
+