aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-04-21 08:09:02 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-24 11:29:37 +0000
commiteb1e0684fa13bd8302878c7ad1a28b6c0303ee3d (patch)
tree04ff3645ee004b3ed76406c9c689377c33b8a364 /unmaintained
parentd71c19dc32bfcd20cc12524c47627f500fa6843f (diff)
downloadaports-eb1e0684fa13bd8302878c7ad1a28b6c0303ee3d.tar.bz2
aports-eb1e0684fa13bd8302878c7ad1a28b6c0303ee3d.tar.xz
unmaintained/enchant: move from main
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/enchant/APKBUILD42
-rw-r--r--unmaintained/enchant/hunspell-build-fix.patch14
2 files changed, 56 insertions, 0 deletions
diff --git a/unmaintained/enchant/APKBUILD b/unmaintained/enchant/APKBUILD
new file mode 100644
index 0000000000..9b6183d77c
--- /dev/null
+++ b/unmaintained/enchant/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=enchant
+pkgver=1.6.0
+pkgrel=14
+pkgdesc="A wrapper library for generic spell checking"
+url="http://www.abisource.com/enchant/"
+arch="all"
+license="LGPL-2.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="aspell-dev glib-dev dbus-glib-dev hunspell-dev gettext-dev file
+ bash"
+source="http://www.abisource.com/downloads/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+ hunspell-build-fix.patch"
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"/tests
+ ./test-enchant
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137 enchant-1.6.0.tar.gz
+c0b7fd8fd00a81ea2c08ea7ce2bdffa826b5a3a0c06eacb818681f0f977d8e76c69f7938c10cdf71571cd1cbbf0e576d36fc74a41755fb570e047525195aeb99 hunspell-build-fix.patch"
diff --git a/unmaintained/enchant/hunspell-build-fix.patch b/unmaintained/enchant/hunspell-build-fix.patch
new file mode 100644
index 0000000000..0ecdb24b30
--- /dev/null
+++ b/unmaintained/enchant/hunspell-build-fix.patch
@@ -0,0 +1,14 @@
+diff -ru enchant-1.6.0-orig/src/myspell/myspell_checker.cpp enchant-1.6.0/src/myspell/myspell_checker.cpp
+--- enchant-1.6.0-orig/src/myspell/myspell_checker.cpp 2016-04-18 12:25:00.094614256 +0100
++++ enchant-1.6.0/src/myspell/myspell_checker.cpp 2016-04-18 12:26:09.108569576 +0100
+@@ -148,6 +148,10 @@
+ g_iconv_close(m_translate_out);
+ }
+
++#ifndef MAXWORDLEN
++# define MAXWORDLEN 100
++#endif
++
+ bool
+ MySpellChecker::checkWord(const char *utf8Word, size_t len)
+ {