aboutsummaryrefslogtreecommitdiffstats
path: root/x11/imlib2/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-19 20:12:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-19 20:12:29 +0000
commitf02518242e005b0c2c14c32062fa4f7b715c3b24 (patch)
treeced3cb8c0569d94ba74838c1c7cdcec792a69784 /x11/imlib2/APKBUILD
parent4f9f28eedbab9533a028d259173c5b6f03889d35 (diff)
downloadaports-f02518242e005b0c2c14c32062fa4f7b715c3b24.tar.bz2
aports-f02518242e005b0c2c14c32062fa4f7b715c3b24.tar.xz
x11/imlib2: new aport
Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support http://sourceforge.net/projects/enlightenment/
Diffstat (limited to 'x11/imlib2/APKBUILD')
-rw-r--r--x11/imlib2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/imlib2/APKBUILD b/x11/imlib2/APKBUILD
new file mode 100644
index 0000000000..d4d509aa1d
--- /dev/null
+++ b/x11/imlib2/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=imlib2
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
+url="http://sourceforge.net/projects/enlightenment/"
+license="BSD"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc libx11 libxext freetype giflib libid3tag libjpeg libpng tiff
+ zlib"
+makedepends="tiff-dev giflib-dev bzip2-dev freetype-dev libxext-dev
+ libpng-dev libid3tag-dev libjpeg-dev libsm-dev zlib-dev"
+source="http://downloads.sourceforge.net/enlightenment/$pkgname-$pkgver.tar.bz2
+ bufferoverflow.patch"
+
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ patch -Np0 -i $srcdir/bufferoverflow.patch || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/imlib2 \
+ --x-libraries=/usr/lib \
+ --disable-mmx \
+ --disable-amd64 \
+ || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="9f15568e76ebda9092c571e0df261f54 imlib2-1.4.2.tar.bz2
+76def1fe0ac2ac1686ff24d29979606f bufferoverflow.patch"