aboutsummaryrefslogtreecommitdiffstats
path: root/x11/wine/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-13 11:15:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-13 11:15:17 +0000
commit5450ef2df9517e6cf8b23eeda69ded9d6036319e (patch)
tree4e48c52874866fe388ece8f65e203b266212f26e /x11/wine/APKBUILD
parent83034c5eccfc66cade38c53faea2524b7d472da0 (diff)
downloadaports-5450ef2df9517e6cf8b23eeda69ded9d6036319e.tar.bz2
aports-5450ef2df9517e6cf8b23eeda69ded9d6036319e.tar.xz
x11/wine: new aport
A compatibility layer for running Windows programs http://www.winehq.com
Diffstat (limited to 'x11/wine/APKBUILD')
-rw-r--r--x11/wine/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11/wine/APKBUILD b/x11/wine/APKBUILD
new file mode 100644
index 0000000000..aae298c830
--- /dev/null
+++ b/x11/wine/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wine
+pkgver=1.1.29
+pkgrel=0
+pkgdesc="A compatibility layer for running Windows programs"
+url="http://www.winehq.com"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+# lcms
+source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --with-x
+ make depend || return 1
+ make || return 1
+ make prefix="$pkgdir"/usr install || return 1
+ mkdir -p "$pkgdir"/etc/wine
+}
+md5sums="c3a9218840a80b29932cee49f2d45d9d wine-1.1.29.tar.bz2
+63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"