aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-notifyd/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-02 12:46:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-02 12:46:47 +0000
commitaac14bc2c48ab890081ab8e9a2c57f6c5a85a49b (patch)
tree60288f424ddcf9a8cdd924d124af101b87a30efe /x11/xfce4-notifyd/APKBUILD
parent5d8f74148ddc88d96794a963f676c658959c37d9 (diff)
downloadaports-aac14bc2c48ab890081ab8e9a2c57f6c5a85a49b.tar.bz2
aports-aac14bc2c48ab890081ab8e9a2c57f6c5a85a49b.tar.xz
x11/xfce4-notifyd: new aport
notification daemon for the xfce desktop http://spuriousinterrupt.org/projects/xfce4-notifyd
Diffstat (limited to 'x11/xfce4-notifyd/APKBUILD')
-rw-r--r--x11/xfce4-notifyd/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/xfce4-notifyd/APKBUILD b/x11/xfce4-notifyd/APKBUILD
new file mode 100644
index 0000000000..717b68470d
--- /dev/null
+++ b/x11/xfce4-notifyd/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-notifyd
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="notification daemon for the xfce desktop"
+url="http://spuriousinterrupt.org/projects/xfce4-notifyd"
+license="GPL2"
+depends="hicolor-icon-theme"
+makedepends="gtk+-dev libxfce4util libxfcegui4-dev libsexy-dev xfconf-dev
+ dbus-glib-dev libglade-dev intltool"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+source="http://spuriousinterrupt.org/files/$pkgname/$pkgname-$pkgver.tar.bz2
+ $install"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 --localstatedir=/var --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="659ecaf37f0f7ee9e31f7b25f9813778 xfce4-notifyd-0.1.0.tar.bz2
+db51db79681eadc47be4932355a77c25 xfce4-notifyd.post-install
+db51db79681eadc47be4932355a77c25 xfce4-notifyd.post-upgrade
+db51db79681eadc47be4932355a77c25 xfce4-notifyd.post-deinstall"