aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-02 18:32:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-02 18:32:19 +0000
commite34a4aa8dfee80c3e764fc1633753b8ce541342b (patch)
tree42791044ec1c89f8f3d2967fe55370b20e642ab9 /x11
parent1e28c63f709a3dedd6c4ab25b495ef7c1a13da36 (diff)
downloadaports-e34a4aa8dfee80c3e764fc1633753b8ce541342b.tar.bz2
aports-e34a4aa8dfee80c3e764fc1633753b8ce541342b.tar.xz
x11/libmpeg2: rebuild
Diffstat (limited to 'x11')
-rw-r--r--x11/libmpeg2/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11/libmpeg2/APKBUILD b/x11/libmpeg2/APKBUILD
index 8b44458e32..15704d0def 100644
--- a/x11/libmpeg2/APKBUILD
+++ b/x11/libmpeg2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmpeg2
pkgver=0.5.1
-pkgrel=0
+pkgrel=1
pkgdesc="libmpeg2 is a library for decoding MPEG-1 and MPEG-2 video streams."
url="http://libmpeg2.sourceforge.net/"
license="GPL2"
@@ -10,8 +10,7 @@ depends=
makedepends="libx11-dev libice-dev libsm-dev libxext-dev libxv-dev"
source="http://$pkgname.sourceforge.net/files/$pkgname-$pkgver.tar.gz"
-build ()
-{
+build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
--enable-shared \
@@ -19,6 +18,10 @@ build ()
make OPT_CFLAGS="${CFLAGS}" \
MPEG2DEC_CFLAGS="${CFLAGS}" \
LIBMPEG2_CFLAGS="" || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}