aboutsummaryrefslogtreecommitdiffstats
path: root/.travis/build-pkgs
diff options
context:
space:
mode:
Diffstat (limited to '.travis/build-pkgs')
-rwxr-xr-x.travis/build-pkgs12
1 files changed, 6 insertions, 6 deletions
diff --git a/.travis/build-pkgs b/.travis/build-pkgs
index 8dcf8ba21e..3d20f0754c 100755
--- a/.travis/build-pkgs
+++ b/.travis/build-pkgs
@@ -4,15 +4,15 @@ set -eu
. "$(dirname "$0")"/common.sh
-# Prints names of top-level directories (i.e. repositories) that has been
-# changed/created in the specified revisions.
+# Prints names of repositories (top-level directories), in defined order,
+# that has been changed/created in the specified revisions.
changed_repos() {
local commit_ish="$1"
- local repos="$(find * -type d -maxdepth 0 ! -name '.*' ! -name 'scripts')"
- # Print names of dirs in the current directory (it's *not* recursive)
- # that contain some changes and consider only dirs listed in $repos.
- git diff-tree --name-only "$commit_ish" -- $repos
+ local repo; for repo in main community testing non-free unmaintained; do
+ git diff-tree --exit-code "$commit_ish" -- $repo >/dev/null \
+ || echo "$repo"
+ done
}
# Prints names of repo's subdirs (i.e. abuilds) that contains APKBUILDs which