aboutsummaryrefslogtreecommitdiffstats
path: root/.travis
diff options
context:
space:
mode:
Diffstat (limited to '.travis')
-rwxr-xr-x.travis/build-pkgs5
1 files changed, 4 insertions, 1 deletions
diff --git a/.travis/build-pkgs b/.travis/build-pkgs
index 6c65407041..75fc444674 100755
--- a/.travis/build-pkgs
+++ b/.travis/build-pkgs
@@ -8,8 +8,11 @@ set -eu
# changed/created in the specified revisions.
changed_repos() {
local commit_ish="$1"
+ local repos="$(find * -type d -maxdepth 0 ! -name '.*')"
- git diff-tree --name-only "$commit_ish" | grep -v '^\..*' || echo ''
+ # Print names of dirs in the current directory (it's *not* recursive)
+ # that contain some changes and consider only dirs listed in $repos.
+ git diff-tree --name-only "$commit_ish" -- $repos
}
# Prints names of repo's subdirs (i.e. abuilds) that contains APKBUILDs which