aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/xz/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/xz/APKBUILD b/testing/xz/APKBUILD
new file mode 100644
index 0000000000..b286376308
--- /dev/null
+++ b/testing/xz/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xz
+pkgver=5.0.0
+pkgrel=0
+pkgdesc="Library and command line tools for XZ and LZMA compressed files"
+url="http://tukaani.org/xz/"
+arch="all"
+license="GPL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://tukaani.org/xz/xz-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --enable-werror
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Libraries for decoding LZMA compression"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f3c0706d100ad2b6d63327584d026c50 xz-5.0.0.tar.gz"