aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/openssl/APKBUILD4
-rw-r--r--main/quagga/APKBUILD4
-rw-r--r--main/quagga/quagga.post-install9
l---------main/quagga/quagga.post-upgrade1
-rw-r--r--testing/irqbalance/APKBUILD44
-rw-r--r--testing/irqbalance/irqbalance.confd19
-rw-r--r--testing/irqbalance/irqbalance.initd25
7 files changed, 102 insertions, 4 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 430203e742..aedafa4930 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openssl
-pkgver=1.0.1b
+pkgver=1.0.1c
pkgrel=0
pkgdesc="Toolkit for SSL v2/v3 and TLS v1"
url="http://openssl.org"
@@ -68,7 +68,7 @@ libssl() {
done
}
-md5sums="a1da58ce63baef3812004714fa302c47 openssl-1.0.1b.tar.gz
+md5sums="ae412727c8c15b67880aef7bd2999b2e openssl-1.0.1c.tar.gz
115c481cd59b3dba631364e8fb1778f5 fix-manpages.patch
c6a9857a5dbd30cead0404aa7dd73977 openssl-bb-basename.patch
1f607b8e11347e56a0906756f3d6928a 0001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch
diff --git a/main/quagga/APKBUILD b/main/quagga/APKBUILD
index 17b14cf83a..49830a099c 100644
--- a/main/quagga/APKBUILD
+++ b/main/quagga/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quagga
pkgver=0.99.21
-pkgrel=0
+pkgrel=1
pkgdesc="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
url="http://quagga.net/"
arch="all"
@@ -9,7 +9,7 @@ license="GPL-2"
depends="iproute2"
makedepends="readline-dev ncurses-dev gawk
autoconf automake libtool"
-install="$pkgname.pre-install"
+install="$pkgname.pre-install $pkgname.post-install $pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-doc"
pkgusers="quagga"
pkggroups="quagga"
diff --git a/main/quagga/quagga.post-install b/main/quagga/quagga.post-install
new file mode 100644
index 0000000000..b4bcef1e7b
--- /dev/null
+++ b/main/quagga/quagga.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# early quaggas had an entry in ld.so.conf. We dont need it anymore
+if [ -r /etc/ld.so.conf ]; then
+ sed -i -e '/usr\/lib\/quagga/d' /etc/ld.so.conf
+ # remove if zero sized
+ [ -s /etc/ld.so.conf ] || rm /etc/ld.so.conf
+fi
+exit 0
diff --git a/main/quagga/quagga.post-upgrade b/main/quagga/quagga.post-upgrade
new file mode 120000
index 0000000000..333e79c3a8
--- /dev/null
+++ b/main/quagga/quagga.post-upgrade
@@ -0,0 +1 @@
+quagga.post-install \ No newline at end of file
diff --git a/testing/irqbalance/APKBUILD b/testing/irqbalance/APKBUILD
new file mode 100644
index 0000000000..18db6b8795
--- /dev/null
+++ b/testing/irqbalance/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=irqbalance
+pkgver=1.0.3
+pkgrel=2
+pkgdesc="Daemon that distributes interrupts over the processors"
+url="http://code.google.com/p/irqbalance/"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev glib-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://irqbalance.googlecode.com/files/$pkgname-$pkgver.tar.gz
+ irqbalance.confd
+ irqbalance.initd"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="6f246481d6295bcb9a79751c03207c96 irqbalance-1.0.3.tar.gz
+731fa9a46bc4fa380604bfb76d96d1ed irqbalance.confd
+25fb4cee9e7b6fc243c10e82c43d0d8d irqbalance.initd"
diff --git a/testing/irqbalance/irqbalance.confd b/testing/irqbalance/irqbalance.confd
new file mode 100644
index 0000000000..2761cfcd35
--- /dev/null
+++ b/testing/irqbalance/irqbalance.confd
@@ -0,0 +1,19 @@
+# /etc/conf.d/irqbalance: config file for /etc/init.d/irqbalance
+
+# Additional options to pass to irqbalance itself.
+IRQBALANCE_OPTS=""
+
+# These are envvars used by irqbalance itself, so make sure the "export"
+# is retained. For more info, please see the irqbalance manpage.
+
+# Run irqbalance once and then exit
+#export IRQBALANCE_ONESHOT="0"
+
+# Include debug messages in output
+#export IRQBALANCE_DEBUG="0"
+
+# List of cpus to not include in balancing
+#export IRQBALANCE_BANNED_CPUS=""
+
+# List of interrupts to not include in balancing
+#export IRQBALANCE_BANNED_INTERRUPTS=""
diff --git a/testing/irqbalance/irqbalance.initd b/testing/irqbalance/irqbalance.initd
new file mode 100644
index 0000000000..11b18a379a
--- /dev/null
+++ b/testing/irqbalance/irqbalance.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/files/irqbalance.init,v 1.5 2012/01/07 22:04:49 vapier Exp $
+
+depends() {
+ need localmount
+ after hwdrivers modules
+}
+
+ssd() {
+ start-stop-daemon --exec /usr/sbin/irqbalance "$@"
+}
+
+start() {
+ ebegin "Starting irqbalance"
+ ssd --start -- ${IRQBALANCE_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping irqbalance"
+ ssd --stop
+ eend $?
+}