aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pyphen/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/py3-pyphen/APKBUILD b/testing/py3-pyphen/APKBUILD
index fa7f770275..d6a76865cd 100644
--- a/testing/py3-pyphen/APKBUILD
+++ b/testing/py3-pyphen/APKBUILD
@@ -5,12 +5,13 @@ _pkgname=Pyphen
pkgver=0.9.5
pkgrel=1
pkgdesc="python-based dictionary hyphenator library"
-url="http://www.pyphen.org/"
+url="https://www.pyphen.org"
arch="noarch"
-license="GPL-2.0-or-later MPL LGPL-2.0-or-later"
+license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pyphen" # Backwards compatibility
@@ -21,11 +22,11 @@ build() {
}
check() {
- python3 setup.py test
+ py.test-3 -v test.py
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="15b9a29517df2b873b5b8d4739d8fa48a09ab199ab9246c7a4fd25c46253a74a18a88fd9484978476b3b1c8d88fed7729382b9dbe4f425724fe54bcd6227de96 Pyphen-0.9.5.tar.gz"
+sha512sums="049a62b226e90e568c8f56e756f8fa6fbc74f3bc40d61af8eb05ff2d4404a7b29cef14d4f144d68ed2f2b11eb128491de64536240ba7b76a2d04010c76e10346 Pyphen-0.9.5.tar.gz"