aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-dpath/APKBUILD (renamed from testing/py-dpath/APKBUILD)12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-dpath/APKBUILD b/testing/py3-dpath/APKBUILD
index 8b341a38ea..2066a137d0 100644
--- a/testing/py-dpath/APKBUILD
+++ b/testing/py3-dpath/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-dpath
+pkgname=py3-dpath
_pkgname=dpath
pkgver=1.4.2
pkgrel=0
@@ -8,20 +8,22 @@ pkgdesc="Filesystem-like pathing and searching for dictionaries"
url="https://www.github.com/akesterson/dpath-python"
arch="noarch"
license="MIT"
-depends="python2"
-makedepends="python2-dev py-setuptools"
+provides="py-dpath" # for backwards compatibility
+replaces="py-dpath=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="8b868ba63a810ef18a58a6452cf6f30eeeee44ea4bd27dbc7d0efcce116adcbb3e2793e89bf94a5aa2d8ec893f96c32dd523f102e5a0da5124a88c7d1dff00d2 dpath-1.4.2.tar.gz"