aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ledger/APKBUILD10
-rw-r--r--testing/ledger/fix-build-with-new-boost.patch26
2 files changed, 4 insertions, 32 deletions
diff --git a/testing/ledger/APKBUILD b/testing/ledger/APKBUILD
index 421e7afb94..b9a17b2587 100644
--- a/testing/ledger/APKBUILD
+++ b/testing/ledger/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=ledger
-pkgver=3.1.1
-pkgrel=2
+pkgver=3.1.3
+pkgrel=0
pkgdesc="Double-entry accounting system with a command-line reporting interface"
url="https://www.ledger-cli.org/"
arch="all"
@@ -10,8 +10,7 @@ license="BSD"
makedepends="cmake boost-dev gmp-dev mpfr-dev texinfo graphviz doxygen gettext"
subpackages="$pkgname-doc"
options="!check" # FIXME: some tests are failing
-source="$pkgname-$pkgver.tar.gz::https://github.com/ledger/$pkgname/archive/v$pkgver.tar.gz
- fix-build-with-new-boost.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ledger/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -31,5 +30,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3f81b98a414cdfc0e272de4e958770149fb1acc8bda880d270e1459ce35294a220c52820bb9af49a751ac3a80b878f81fc7799ba41e0a1be43eba72081351bf5 ledger-3.1.1.tar.gz
-1a70bf192425b19abc34bb00ee84621e5a069fbe8fdcd56593d8c0dd3b8676f40c6a6c30c488320d22fd206eeb09db7ee7d1f8a2b3ffdb996c5978f98160cdbb fix-build-with-new-boost.patch"
+sha512sums="a2a63c80d7313f94eca5d8701ab623ccbe483972b4194bcc7a99dabe8f615b55aba0b933848295de3b3ac8bfb2b71d1d65c73eef315905678ad332695eebbf75 ledger-3.1.3.tar.gz"
diff --git a/testing/ledger/fix-build-with-new-boost.patch b/testing/ledger/fix-build-with-new-boost.patch
deleted file mode 100644
index fddef9199f..0000000000
--- a/testing/ledger/fix-build-with-new-boost.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From a4436f782c4a6b7f919b74110939113af60fa5e7 Mon Sep 17 00:00:00 2001
-From: Alexis Hildebrandt <afh@surryhill.net>
-Date: Mon, 26 Sep 2016 18:19:52 +0200
-Subject: [PATCH] Merge pull request #465 from dkasak/patch-1
-
-Fix compilation error with boost 1.61
----
- src/item.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/item.h b/src/item.h
-index ca16d87b..4dc6df7e 100644
---- a/src/item.h
-+++ b/src/item.h
-@@ -92,7 +92,7 @@ public:
-
- typedef std::pair<optional<value_t>, bool> tag_data_t;
- typedef std::map<string, tag_data_t,
-- function<bool(string, string)> > string_map;
-+ std::function<bool(string, string)> > string_map;
-
- state_t _state;
- optional<date_t> _date;
---
-2.16.2
-