aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/dynamips/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/dynamips/APKBUILD b/community/dynamips/APKBUILD
index 930f72107c..77a7c37cc2 100644
--- a/community/dynamips/APKBUILD
+++ b/community/dynamips/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dynamips
pkgver=0.2.16
-pkgrel=1
+pkgrel=2
pkgdesc="Cisco router emulator"
url="https://github.com/GNS3/dynamips"
arch="all"
@@ -13,6 +13,12 @@ source="${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/
s390x-support.patch"
builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$builddir"
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake
+ default_prepare
+}
+
build() {
cd "$builddir"
if test $CARCH == x86_64; then