aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libxml++-2.6/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libxml++-2.6/APKBUILD b/testing/libxml++-2.6/APKBUILD
new file mode 100644
index 0000000000..6cc4ebb668
--- /dev/null
+++ b/testing/libxml++-2.6/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libxml++-2.6
+_pkgname=libxml++
+pkgver=2.40.1
+pkgrel=0
+pkgdesc="libbxml++ is a C++ wrapper for the libxml XML parser library."
+url="http://libxmlplusplus.sourceforge.net/"
+arch="all"
+license="GPL2"
+makedepends="libxml2-dev glibmm-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver%.[0-9]*}/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 $pkgname.pc "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+
+sha512sums="a4ec2e8182d981c57bdcb8f0a203a3161f8c735ceb59fd212408b7a539d1dc826adf6717bed8f4d544ab08afd9c2fc861efe518e24bbd3a1c4b158e2ca48183a libxml++-2.40.1.tar.xz"