aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/acf-shorewall/APKBUILD6
-rw-r--r--main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch27
-rw-r--r--main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch46
-rw-r--r--main/apk-tools/APKBUILD10
-rw-r--r--main/sylpheed/APKBUILD8
-rw-r--r--main/sysklogd/APKBUILD3
-rw-r--r--main/sysklogd/sysklogd.post-install5
-rw-r--r--main/sysklogd/sysklogd.pre-deinstall5
-rw-r--r--testing/backuppc/APKBUILD4
9 files changed, 24 insertions, 90 deletions
diff --git a/main/acf-shorewall/APKBUILD b/main/acf-shorewall/APKBUILD
index 025026776d..c834929e58 100644
--- a/main/acf-shorewall/APKBUILD
+++ b/main/acf-shorewall/APKBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-shorewall
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=0
pkgdesc="A web-based system administration interface for shorewall"
url="http://git.alpinelinux.org/cgit/acf-shorewall"
@@ -12,4 +12,4 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-md5sums="218dc8f6115da0223b70284bde1066e9 acf-shorewall-0.6.1.tar.bz2"
+md5sums="d92c0f4ebdbe52dff156a13c08055cf9 acf-shorewall-0.6.2.tar.bz2"
diff --git a/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch b/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch
deleted file mode 100644
index b025a9b783..0000000000
--- a/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d67ee300b6cbd9deaaa8c5e506e836e253f7b77d Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 25 Dec 2009 07:02:32 +0000
-Subject: [PATCH 1/2] state: Default interactive action is Yes
-
-When pressing only <enter> on the question "..continue [Y/n]?" then
-lets take that as a "yes"
----
- src/state.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/state.c b/src/state.c
-index 94afe86..1bd29bf 100644
---- a/src/state.c
-+++ b/src/state.c
-@@ -771,7 +771,7 @@ int apk_state_commit(struct apk_state *state,
- printf("Do you want to continue [Y/n]? ");
- fflush(stdout);
- r = fgetc(stdin);
-- if (r != 'y' && r != 'Y')
-+ if (r != 'y' && r != 'Y' && r != '\n')
- return -1;
- }
- }
---
-1.6.5.7
-
diff --git a/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch b/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch
deleted file mode 100644
index 3061ed5609..0000000000
--- a/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 3f9fe4c28be7987bd404f06e27ed03aafd8e8b52 Mon Sep 17 00:00:00 2001
-From: Timo Teras <timo.teras@iki.fi>
-Date: Fri, 25 Dec 2009 14:14:40 +0200
-Subject: [PATCH 2/2] db: keep packages with no files with installed status
-
-got broke few commits ago when apk_pkg_installed() call was
-moved to happen after the package name has been read.
----
- src/database.c | 16 ++++++++++------
- 1 files changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/src/database.c b/src/database.c
-index 5118f5c..2fcb275 100644
---- a/src/database.c
-+++ b/src/database.c
-@@ -587,17 +587,21 @@ int apk_db_index_read(struct apk_database *db, struct apk_bstream *bs, int repo)
- }
-
- /* Standard index line? */
-- if (apk_pkg_add_info(db, pkg, field, l) == 0)
-+ if (apk_pkg_add_info(db, pkg, field, l) == 0) {
-+ if (repo == -1 && field == 'S') {
-+ /* Instert to installed database; this needs to
-+ * happen after package name has been read, but
-+ * before first FDB entry. */
-+ ipkg = apk_pkg_install(db, pkg);
-+ diri_node = hlist_tail_ptr(&ipkg->owned_dirs);
-+ }
- continue;
-+ }
-
-- if (repo != -1) {
-+ if (repo != -1 || ipkg == NULL) {
- apk_error("Invalid index entry '%c'", field);
- return -1;
- }
-- if (ipkg == NULL) {
-- ipkg = apk_pkg_install(db, pkg);
-- diri_node = hlist_tail_ptr(&ipkg->owned_dirs);
-- }
-
- /* Check FDB special entries */
- switch (field) {
---
-1.6.5.7
-
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 3db72d348d..3e81ac8568 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,14 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0
-pkgrel=1
+pkgver=2.0.1
+pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- 0001-state-Default-interactive-action-is-Yes.patch
- 0002-db-keep-packages-with-no-files-with-installed-status.patch
"
@@ -42,6 +40,4 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="dc827e62065c940bbcec1c93099a5718 apk-tools-2.0.tar.bz2
-36e514cbc781759dbb6eb84e35f6072d 0001-state-Default-interactive-action-is-Yes.patch
-180368300d46c5b6de0d5eb43d90547e 0002-db-keep-packages-with-no-files-with-installed-status.patch"
+md5sums="0412a168cdc15066a5ae2015fb9cba01 apk-tools-2.0.1.tar.bz2"
diff --git a/main/sylpheed/APKBUILD b/main/sylpheed/APKBUILD
index f0fe701c21..3455b1c7d5 100644
--- a/main/sylpheed/APKBUILD
+++ b/main/sylpheed/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sylpheed
-pkgver=2.7.1
-pkgrel=2
+pkgver=3.0.0
+pkgrel=0
pkgdesc="Lightweight and user-friendly e-mail client"
url="http://sylpheed.sraoss.jp/en/"
license="GPL"
depends=
makedepends="gtk+-dev openldap-dev openssl-dev"
subpackages="$pkgname-dev"
-source="http://$pkgname.sraoss.jp/$pkgname/v2.7/$pkgname-$pkgver.tar.bz2"
+source="http://$pkgname.sraoss.jp/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
build() {
cd "$srcdir/sylpheed-$pkgver"
@@ -22,4 +22,4 @@ package() {
cd "$srcdir/sylpheed-$pkgver"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="1f470525c1fbe53253813a0978c18228 sylpheed-2.7.1.tar.bz2"
+md5sums="bb2cf4adfa9577746f54a516e9471bfd sylpheed-3.0.0.tar.bz2"
diff --git a/main/sysklogd/APKBUILD b/main/sysklogd/APKBUILD
index d7c83423dc..33dde41e43 100644
--- a/main/sysklogd/APKBUILD
+++ b/main/sysklogd/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysklogd
pkgver=1.5
-pkgrel=3
+pkgrel=4
pkgdesc="System and kernel log daemons"
url="http://www.infodrom.org/projects/sysklogd/"
license="GPL BSD"
subpackages="$pkgname-doc"
depends=
makedepends=""
+install="sysklogd.post-install sysklogd.pre-deinstall"
source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
sysklogd.logrotate
sysklogd.daily
diff --git a/main/sysklogd/sysklogd.post-install b/main/sysklogd/sysklogd.post-install
new file mode 100644
index 0000000000..498880c53f
--- /dev/null
+++ b/main/sysklogd/sysklogd.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+INIT=syslog
+RUNLEVEL=`rc-update show | grep $INIT | awk '{ print $3 }'`
+rc-update del $INIT $RUNLEVEL
+rc-update add sysklogd $RUNLEVEL
diff --git a/main/sysklogd/sysklogd.pre-deinstall b/main/sysklogd/sysklogd.pre-deinstall
new file mode 100644
index 0000000000..4ed8f79f15
--- /dev/null
+++ b/main/sysklogd/sysklogd.pre-deinstall
@@ -0,0 +1,5 @@
+#!/bin/sh
+INIT=sysklogd
+RUNLEVEL=`rc-update show | grep $INIT | awk '{ print $3 }'`
+rc-update del $INIT $RUNLEVEL
+rc-update add syslog $RUNLEVEL
diff --git a/testing/backuppc/APKBUILD b/testing/backuppc/APKBUILD
index 355be87929..05de31bcbb 100644
--- a/testing/backuppc/APKBUILD
+++ b/testing/backuppc/APKBUILD
@@ -4,14 +4,14 @@ pkgname="backuppc"
_realname="BackupPC"
pkgver="3.2.0b1"
_realver="3.2.0beta1"
-pkgrel=3
+pkgrel=4
pkgdesc="High-performance, enterprise-grade backup system"
url="http://backuppc.sourceforge.net/"
license="GPL"
depends="perl busybox rsync perl-archive-zip perl-io-compress
perl-libwww perl-file-rsync"
makedepends=""
-install="$pkgname.pre-install"
+install="$pkgname.pre-install $pkgname.post-install"
subpackages=""
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-beta/$_realver/$_realname-$_realver.tar.gz
configure.pl.patch"