aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/php/APKBUILD12
-rw-r--r--main/php/php-fix-crypt.patch41
2 files changed, 4 insertions, 49 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 261463e64f..b5a81946a4 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php
-pkgver=5.6.20
+pkgver=5.6.21
pkgrel=0
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
@@ -110,7 +110,6 @@ source="http://php.net/distributions/php-$pkgver.tar.bz2
php5-module.conf
php-install-pear-xml.patch
gd-iconv.patch
- php-fix-crypt.patch
fix-crypt-sha.patch
"
@@ -497,24 +496,21 @@ pdo_dblib() { _mv_ext pdo_dblib "php-pdo freetds"; }
wddx() { _mv_ext wddx; }
opcache() { _mv_ext opcache; }
-md5sums="e6422449bb0342f074eb649a9adf586b php-5.6.20.tar.bz2
+md5sums="141464ce6b297aa2295b8416c6dbd5e5 php-5.6.21.tar.bz2
08932656a9fe2d0b329805097efb033a php-fpm.initd
67719f428f44ec004da18705cbabe2ee php5-module.conf
483bc0a85c50a9a9aedbe14a19ed4526 php-install-pear-xml.patch
162d8d079944387eab2bc80edab347ae gd-iconv.patch
-b63ef63893c1c115d6dd63e8df1f17e3 php-fix-crypt.patch
cb10034c525c6544890f1a1839837e38 fix-crypt-sha.patch"
-sha256sums="5ac7bf7caec7a79b18cf458e786fd1609ad2da771224b80bc15cc6f01b22bf1f php-5.6.20.tar.bz2
+sha256sums="b4ed7ab574b689fd6d6494fde954826c06efc85c505e017b8d776c7c7f479590 php-5.6.21.tar.bz2
c60b956b909c347de57265654c76b6fb903248adc709c07966a39584a3ef65fe php-fpm.initd
ceec4d5b2a128c6a97e49830af604f0bb555bca1a86a9cd0366b828ba392257f php5-module.conf
f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab php-install-pear-xml.patch
6122bf279cdb7c387dd000761b2426969a73cf63a10a132aa98a79eb1dd259b2 gd-iconv.patch
-817f6300cd0c4d97f24c3e883132d2cde0ef52d84f5c97073f9c9668d6275d6e php-fix-crypt.patch
a5db307ad2638e7e609b450abce19c98c23de54be96619b46adb69f2c5e11fa2 fix-crypt-sha.patch"
-sha512sums="9e26f2564ee7329ab50d4d8d27f029c4f88317ea761888138e60d13a3cf51e49676ded406a3ec18433be2ec5d2a49c904eaa9f32d473b99d11550025e026a61c php-5.6.20.tar.bz2
+sha512sums="028d62434e7932b4a07fa7d404b8ad938f0ca7968ae2b23386038f77482984d2b6145523e11f37b9e72621c8bf40f08e38a6db1d209493770ac99e13e2fac0d0 php-5.6.21.tar.bz2
f88eb6b44d1418d2373a7a0de56e17bc392b5afd87a9a3953183f2dcb62cfd8e5ac9ba8a5c481efce4058a68624c0be88b42c804fc386175cda158b71c82bea7 php-fpm.initd
895e94c791bd82060ad820fef049d366a09c932097faa6b7b9a2c2e9e00a18cb7c0f9b128679c7659b404379266fd0f95dba5c0333f626194cf60f7bf6044102 php5-module.conf
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 php-install-pear-xml.patch
59443fb464f49ff7d9b64739df982e7240f9d4792226d96ad1538286945125fc7eb6f0cab88b64d5c81ee3679fd89bffdca59ebd20eca2778ab801ee54529028 gd-iconv.patch
-febe75305b19ca7c2b4f85ee8144d3a347530044223619b28fb754485f72fe3dd283ece341d77f2e0bff3881ed7fa2b89e6c95a8e4b077ab40b3f7a8d767a633 php-fix-crypt.patch
d3b156dc7fca33c5634ace04bc7b7f27174d58d09455adf5bcdafd748a6aab1b1c97dce588d218b95d5fde3f6c2dd9202f4d7ea1c3b323be400f4d990c39290b fix-crypt-sha.patch"
diff --git a/main/php/php-fix-crypt.patch b/main/php/php-fix-crypt.patch
deleted file mode 100644
index caa6a2e22d..0000000000
--- a/main/php/php-fix-crypt.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Reported upstream:
-https://bugs.php.net/bug.php?id=67512
-
---- php-5.5.13/ext/standard/crypt.c.orig 2014-06-25 13:10:38.930010191 -0300
-+++ php-5.5.13/ext/standard/crypt.c 2014-06-25 13:45:09.762124864 -0300
-@@ -228,18 +228,20 @@
- }
- }
- #else
--
--# if defined(HAVE_CRYPT_R) && (defined(_REENTRANT) || defined(_THREAD_SAFE))
- {
--# if defined(CRYPT_R_STRUCT_CRYPT_DATA)
-+# if defined(HAVE_CRYPT_R)
-+# if defined(CRYPT_R_STRUCT_CRYPT_DATA)
- struct crypt_data buffer;
- memset(&buffer, 0, sizeof(buffer));
--# elif defined(CRYPT_R_CRYPTD)
-+# elif defined(CRYPT_R_CRYPTD)
- CRYPTD buffer;
--# else
--# error Data struct used by crypt_r() is unknown. Please report.
--# endif
-+# else
-+# error Data struct used by crypt_r() is unknown. Please report.
-+# endif
- crypt_res = crypt_r(password, salt, &buffer);
-+# else
-+ crypt_res = crypt(passwrd, salt);
-+#endif
- if (!crypt_res || (salt[0] == '*' && salt[1] == '0')) {
- return FAILURE;
- } else {
-@@ -247,7 +249,6 @@
- return SUCCESS;
- }
- }
--# endif
- #endif
- }
- /* }}} */