aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/phpmyadmin/APKBUILD96
-rw-r--r--testing/phpmyadmin/htaccess3
-rw-r--r--testing/phpmyadmin/phpmyadmin.apache2.conf7
-rw-r--r--testing/phpmyadmin/phpmyadmin.post-install15
4 files changed, 121 insertions, 0 deletions
diff --git a/testing/phpmyadmin/APKBUILD b/testing/phpmyadmin/APKBUILD
new file mode 100644
index 0000000000..8a1529c253
--- /dev/null
+++ b/testing/phpmyadmin/APKBUILD
@@ -0,0 +1,96 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=phpmyadmin
+pkgver=3.3.10
+pkgrel=0
+pkgdesc="A Web-based PHP tool for administering MySQL"
+url="http://www.phpmyadmin.net/"
+arch="noarch"
+license="GPL"
+depends="php php-mysql php-zip php-zlib php-bz2 php-ctype php-gd php-mcrypt mysql"
+depends_dev=
+makedepends="$depends_dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+_fullpkgname=phpMyAdmin-$pkgver-all-languages
+source="http://downloads.sourceforge.net/$pkgname/$_fullpkgname.tar.gz
+ $pkgname.apache2.conf
+ htaccess
+ "
+
+_builddir="$srcdir"/$_fullpkgname
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/webapps/$pkgname \
+ "$pkgdir"/etc/$pkgname \
+ || return 1
+
+ # copy phpmyadmin
+ cp -ra "$_builddir"/* "$pkgdir"/usr/share/webapps/$pkgname/ \
+ || return 1
+
+ # install an htaccess file
+ install -m644 "$srcdir"/htaccess "$pkgdir"/etc/$pkgname/ \
+ || return 1
+ ln -fs /etc/$pkgname/htaccess \
+ "$pkgdir"/usr/share/webapps/$pkgname/.htaccess \
+ || return 1
+
+ # install the sample config
+ install -m660 \
+ "$pkgdir"/usr/share/webapps/$pkgname/config.sample.inc.php \
+ "$pkgdir"/etc/$pkgname/config.inc.php \
+ || return 1
+ ln -fs /etc/$pkgname/config.inc.php \
+ "$pkgdir"/usr/share/webapps/$pkgname/config.inc.php \
+ || return 1
+
+ # install the apache2 config
+ install -Dm644 "$srcdir"/$pkgname.apache2.conf \
+ "$pkgdir"/etc/apache2/conf.d/$pkgname.conf || return 1
+
+ # copy some contribs over
+ mkdir -p "$pkgdir"/usr/share/$pkgname/contrib || return 1
+ _contribs="htaccess swekey.sample.conf"
+ for _contrib in $_contribs; do
+ mv "$pkgdir"/usr/share/webapps/$pkgname/contrib/$_contrib \
+ "$pkgdir"/usr/share/$pkgname/contrib/ \
+ || return 1
+ done
+ rm -rf "$pkgdir"/usr/share/webapps/$pkgname/contrib || return 1
+}
+
+doc() {
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname || return 1
+
+ _docs="CREDITS ChangeLog Documentation.html Documentation.txt \
+ INSTALL LICENSE README README.VENDOR RELEASE-DATE-$pkgver \
+ TODO translators.html documentation-gsoc"
+ for _doc in $_docs; do
+ mv "$pkgdir"/usr/share/webapps/$pkgname/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/ \
+ || return 1
+ done
+
+ mv "$pkgdir"/usr/share/webapps/$pkgname/config.sample.inc.php \
+ "$subpkgdir"/usr/share/doc/$pkgname/ || return 1
+}
+
+md5sums="2e93375a92a86ef36e561b0087f6b8e3 phpMyAdmin-3.3.10-all-languages.tar.gz
+2d144825122042b4a2536ad789d66e8e phpmyadmin.apache2.conf
+a83a095fe9e86d1cdd1424f857e26c9b htaccess"
diff --git a/testing/phpmyadmin/htaccess b/testing/phpmyadmin/htaccess
new file mode 100644
index 0000000000..4666b1f4a4
--- /dev/null
+++ b/testing/phpmyadmin/htaccess
@@ -0,0 +1,3 @@
+allow from 127.0.0.1
+allow from ::1
+deny from all
diff --git a/testing/phpmyadmin/phpmyadmin.apache2.conf b/testing/phpmyadmin/phpmyadmin.apache2.conf
new file mode 100644
index 0000000000..1c1a5f6498
--- /dev/null
+++ b/testing/phpmyadmin/phpmyadmin.apache2.conf
@@ -0,0 +1,7 @@
+Alias /phpmyadmin "/usr/share/webapps/phpmyadmin"
+<Directory "/usr/share/webapps/phpmyadmin">
+ AllowOverride All
+ Options FollowSymlinks
+ Order allow,deny
+ Allow from all
+</Directory>
diff --git a/testing/phpmyadmin/phpmyadmin.post-install b/testing/phpmyadmin/phpmyadmin.post-install
new file mode 100644
index 0000000000..00cd7d2c78
--- /dev/null
+++ b/testing/phpmyadmin/phpmyadmin.post-install
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+echo -e "\nphpMyAdmin has been installed to:"
+echo -e " /usr/share/webapps/phpmyadmin"
+echo -e "phpMyAdmin config files have been installed to:"
+echo -e " /etc/phpmyadmin"
+echo -e "If you use apache2:"
+echo -e " - Change ownership of the config directory:"
+echo -e " chown -R apache:apache /etc/phpmyadmin"
+echo -e " - See if you need to modify the following files:"
+echo -e " /etc/apache2/conf.d/phpmyadmin.conf"
+echo -e " /etc/phpmyadmin/htaccess"
+echo -e " - Restart apache2 when done.\n"
+
+exit 0