aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/lua-lustache/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/lua-lustache/APKBUILD b/main/lua-lustache/APKBUILD
index 3934ee189e..8c4860294b 100644
--- a/main/lua-lustache/APKBUILD
+++ b/main/lua-lustache/APKBUILD
@@ -4,7 +4,7 @@ _pkgname=lustache
pkgname=lua-$_pkgname
pkgver=1.3.1
_pkgver=$pkgver-0
-pkgrel=0
+pkgrel=1
pkgdesc="Logic-less {{mustache}} templates with Lua"
url="http://olivinelabs.com/lustache/"
arch="noarch"
@@ -38,12 +38,16 @@ _package() {
pkgdesc="$pkgdesc $lver"
depends="$pkgname-common lua$lver"
install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+ local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$_pkgname/$_pkgver"
mkdir -p "$subpkgdir"/usr/share/lua/$lver
local path; for path in lustache lustache.lua; do
ln -s ../common/$path "$subpkgdir"/usr/share/lua/$lver/$path \
|| return 1
done
+
+ mkdir -p "$rockdir"
+ echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
md5sums="e4416abe1a822c1b2d4b3a9e702d5795 lua-lustache-1.3.1.tar.gz"