aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/monitoring-plugins/APKBUILD18
-rw-r--r--community/monitoring-plugins/fix-perl.patch12
2 files changed, 6 insertions, 24 deletions
diff --git a/community/monitoring-plugins/APKBUILD b/community/monitoring-plugins/APKBUILD
index d2e2384e2d..8b1cab43ab 100644
--- a/community/monitoring-plugins/APKBUILD
+++ b/community/monitoring-plugins/APKBUILD
@@ -5,25 +5,22 @@ pkgver="2.2"
pkgrel=1
pkgdesc="Plugins for Icinga, Naemon, Nagios, Shinken, Sensu and other monitoring applications"
url="http://www.monitoring-plugins.org"
-arch=""
+arch="all"
license="GPL3"
depends=""
depends_dev=""
options="suid"
makedepends="$depends_dev linux-headers libdbi-dev
- libressl-dev mariadb-dev postgresql-dev perl-dev
- autoconf automake libtool"
+ libressl-dev mariadb-dev postgresql-dev perl-dev"
install=""
subpackages="$pkgname-doc"
-source="https://www.monitoring-plugins.org/download/$pkgname-$pkgver.tar.gz
- fix-perl.patch"
+source="https://www.monitoring-plugins.org/download/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare || return 1
update_config_guess || return 1
update_config_sub || return 1
- autoreconf -vif
}
build() {
@@ -31,9 +28,9 @@ build() {
./configure \
--prefix=/usr \
--libexecdir=/usr/lib/monitoring-plugins \
- --with-perl \
+ --with-perl="$(which perl)" \
--with-openssl \
- --with-pgsql \
+ --with-pgsql=/usr \
--with-dbi \
--with-mysql \
--with-ipv6
@@ -44,8 +41,6 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 LEGAL "$pkgdir"/usr/share/licenses/$pkgname/LEGAL
-
for i in ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog \
FAQ NEWS README REQUIREMENTS SUPPORT THANKS; do
install -Dm644 $i "$pkgdir"/usr/share/doc/$pkgname/$i
@@ -53,5 +48,4 @@ package() {
rm $pkgdir/usr/lib/charset.alias
}
-sha512sums="5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27 monitoring-plugins-2.2.tar.gz
-1bc33fa6e7a0f2aa0648646e7e5118bd6d40c45c56ab0a0bdf4a7fb69c24353ddf5069d76923497ef37067afaa5d35ae5b5fc29a4f7622201a08efd83d1067ba fix-perl.patch"
+sha512sums="5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27 monitoring-plugins-2.2.tar.gz"
diff --git a/community/monitoring-plugins/fix-perl.patch b/community/monitoring-plugins/fix-perl.patch
deleted file mode 100644
index bd24d92aac..0000000000
--- a/community/monitoring-plugins/fix-perl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./configure.ac.orig
-+++ ./configure.ac
-@@ -120,6 +120,9 @@
- ACX_HELP_STRING([--with-perl=PATH],
- [sets path to perl executable]),
- with_perl=$withval,with_perl=$PERL)
-+if test "$with_perl" = "yes"; then
-+ with_perl="$PERL"
-+fi
- AC_SUBST(PERL, $with_perl)
-
- dnl openssl/gnutls