aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py-pysqlite/APKBUILD44
-rw-r--r--testing/py-pysqlite/APKBUILD29
2 files changed, 44 insertions, 29 deletions
diff --git a/community/py-pysqlite/APKBUILD b/community/py-pysqlite/APKBUILD
new file mode 100644
index 0000000000..8d3693b028
--- /dev/null
+++ b/community/py-pysqlite/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=py-pysqlite
+_pkgname=pysqlite
+pkgver=2.8.2
+pkgrel=0
+pkgdesc="Python DB-API 2.0 interface for the SQLite"
+url="https://pypi.python.org/pypi/pysqlite"
+arch="noarch"
+license="MIT"
+subpackages="py2-${pkgname/py-/}:_py2"
+makedepends="python2-dev py-setuptools sqlite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ arch="all"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+md5sums="b8488f6a353bd6a3cd85d327d326376a pysqlite-2.8.2.tar.gz"
+sha256sums="613d139e97ce0561dee312e29f3be4751d01fd1a085aa448dd53a003810e0008 pysqlite-2.8.2.tar.gz"
+sha512sums="7b462d15fa088195da34da4b3a15342ab8a43bdb4628a69c7c6f1804ac01954042c101450270e2968150df9207aa66f7c6a4e852ae03fc676e9ebd651f82f331 pysqlite-2.8.2.tar.gz"
diff --git a/testing/py-pysqlite/APKBUILD b/testing/py-pysqlite/APKBUILD
deleted file mode 100644
index 2e64784e17..0000000000
--- a/testing/py-pysqlite/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Maintainer:
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-
-pkgname=py-pysqlite
-_pkgname=pysqlite
-pkgver=2.6.3
-pkgrel=0
-pkgdesc='Python DB-API 2.0 interface for the SQLite'
-url='http://code.google.com/p/pysqlite/'
-arch='all'
-license='MIT'
-makedepends="python-dev py-setuptools sqlite-dev"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$_builddir"
- python setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="7ff1cedee74646b50117acff87aa1cfa pysqlite-2.6.3.tar.gz"
-sha256sums="fe9c35216bf56c858b34c4b4c8be7e34566ddef29670e5a5b43f9cb8ecfbb28d pysqlite-2.6.3.tar.gz"
-sha512sums="1b8ce3b5300c1d8568ef59d4967ccd06c5e80ea45c2ffdb9d6744712f12b0b2649ade646f926562bf59b660d6d56bfc478780f22577c96cb758f1de7259570a2 pysqlite-2.6.3.tar.gz"