aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/docker-registry/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/docker-registry/APKBUILD b/community/docker-registry/APKBUILD
index 0a2430e708..325482f11d 100644
--- a/community/docker-registry/APKBUILD
+++ b/community/docker-registry/APKBUILD
@@ -31,7 +31,8 @@ build() {
export GOPATH="${DISTRIBUTION_DIR}/Godeps/_workspace"
cd "${DISTRIBUTION_DIR}"
# GOPATH fix
- ln -s "${DISTRIBUTION_DIR}" "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/distribution"
+ mkdir -p "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/" || return 1
+ ln -s "${DISTRIBUTION_DIR}" "${DISTRIBUTION_DIR}/Godeps/_workspace/src/github.com/docker/distribution" || return 1
make clean binaries || return 1
}