aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/xournal/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/xournal/APKBUILD b/testing/xournal/APKBUILD
new file mode 100644
index 0000000000..7cc54acecb
--- /dev/null
+++ b/testing/xournal/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=xournal
+pkgver=0.4.8
+pkgrel=0
+pkgdesc="Notetaking, sketching, keeping a journal using a stylus"
+url="http://xournal.sourceforge.net/"
+arch="all"
+license="GPL2"
+makedepends="libgnomecanvas-dev poppler-dev gtk+2.0-dev libart-lgpl-dev"
+subpackages="$pkgname-lang"
+source="http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="cfd5760a0e832ef02786a29cb744d4932aeee97c4d6992b430e647bd59aaef1042735203824d0eaf9da9b884dcdadcfb8f5acea221638db91438ae46a6ee42bf xournal-0.4.8.tar.gz"