aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/rlog/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/rlog/APKBUILD b/testing/rlog/APKBUILD
index 2cf2f9d4f9..5aa318cccd 100644
--- a/testing/rlog/APKBUILD
+++ b/testing/rlog/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=rlog
pkgver=1.4
-pkgrel=2
+pkgrel=3
pkgdesc="A flexible message logging facility for C++ programs and libraries."
url="http://www.arg0.net/rlog"
arch="all"
@@ -18,6 +18,7 @@ _builddir=${srcdir}/${pkgname}-${pkgver}
prepare() {
local i
cd "$_builddir"
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -27,7 +28,11 @@ prepare() {
build() {
cd "$_builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
make
}