aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/neon/APKBUILD6
-rw-r--r--main/neon/fix-libressl.patch31
2 files changed, 34 insertions, 3 deletions
diff --git a/main/neon/APKBUILD b/main/neon/APKBUILD
index 3ec2bd93dc..21cbdfe90a 100644
--- a/main/neon/APKBUILD
+++ b/main/neon/APKBUILD
@@ -36,8 +36,8 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
md5sums="e28d77bf14032d7f5046b3930704ef41 neon-0.30.2.tar.gz
-dba7462ee605cf9bac56b055311fccd3 fix-libressl.patch"
+ad495360898a5367ef411fa086750044 fix-libressl.patch"
sha256sums="db0bd8cdec329b48f53a6f00199c92d5ba40b0f015b153718d1b15d3d967fbca neon-0.30.2.tar.gz
-5fba4305eabefcad04ba98ab5e0caa25bcc8a2ad5341aaa5186553f24391370a fix-libressl.patch"
+b10b9a213f178012739c3bafe73b5c05a744e746ba41fad4ca0fc2831d341244 fix-libressl.patch"
sha512sums="634caf87522e0bd2695c6fba39cae2465e403f9fbd8007eb10e4e035c765d24cb8da932c67bfa35c34aa51b90c7bc7037ebebaa1ec43259366d5d07233efc631 neon-0.30.2.tar.gz
-afca909b969153afc717ea917cfbf22cd4bf7938cba55284858cf757c682fe961fc045a1822e6fc8abc1d6ce506884afde8088aff269bd150075603c3b9d926b fix-libressl.patch"
+a9ef4d5ef44518ac4df81a3e3d7532cf1eb7ee4018fd9c05ceeff0bc11d368bf2253af410e54142d73503772eb9e470ad6c0c7cd28f08d9d918b9587a685e1fc fix-libressl.patch"
diff --git a/main/neon/fix-libressl.patch b/main/neon/fix-libressl.patch
new file mode 100644
index 0000000000..226e79878e
--- /dev/null
+++ b/main/neon/fix-libressl.patch
@@ -0,0 +1,31 @@
+Version number juggling for libressl
+
+--- a/src/ne_openssl.c 2016-09-30 10:46:00.000000000 +0200
++++ b/src/ne_openssl.c 2016-10-06 00:19:58.366044580 +0200
+@@ -66,7 +66,7 @@
+ typedef const unsigned char ne_d2i_uchar;
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ #define X509_up_ref(x) x->references++
+ #define EVP_PKEY_up_ref(x) x->references++
+ #define EVP_PKEY_get0_RSA(evp) (evp->pkey.rsa)
+@@ -1199,7 +1199,7 @@
+
+ int ne__ssl_init(void)
+ {
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ CRYPTO_malloc_init();
+ SSL_load_error_strings();
+ SSL_library_init();
+@@ -1242,7 +1242,7 @@
+ "for %" NE_FMT_SIZE_T " locks.\n", num_locks);
+ }
+ #endif
+-#endif /* OPENSSL_VERSION_NUMBER < 0x10100000L */
++#endif /* (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) */
+
+ return 0;
+ }