aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/dash/APKBUILD4
-rw-r--r--testing/dash/dash.post-install3
l---------testing/dash/dash.post-upgrade1
-rw-r--r--testing/dash/dash.pre-deinstall3
4 files changed, 9 insertions, 2 deletions
diff --git a/testing/dash/APKBUILD b/testing/dash/APKBUILD
index 6994dc9b6f..b346bf004d 100644
--- a/testing/dash/APKBUILD
+++ b/testing/dash/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dash
pkgver=0.5.7
-pkgrel=0
+pkgrel=1
pkgdesc="Small and fast POSIX-compliant shell"
url="http://gondor.apana.org.au/~herbert/dash/"
arch="all"
@@ -10,7 +10,7 @@ depends=""
depends_dev=""
# needs 'nl' utility from coreutils
makedepends="$depends_dev coreutils"
-install=""
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
source="http://gondor.apana.org.au/~herbert/dash/files/dash-$pkgver.tar.gz"
diff --git a/testing/dash/dash.post-install b/testing/dash/dash.post-install
new file mode 100644
index 0000000000..69af64bb04
--- /dev/null
+++ b/testing/dash/dash.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/bin/dash'
+exit 0
diff --git a/testing/dash/dash.post-upgrade b/testing/dash/dash.post-upgrade
new file mode 120000
index 0000000000..3514e3b3c1
--- /dev/null
+++ b/testing/dash/dash.post-upgrade
@@ -0,0 +1 @@
+dash.post-install \ No newline at end of file
diff --git a/testing/dash/dash.pre-deinstall b/testing/dash/dash.pre-deinstall
new file mode 100644
index 0000000000..07f1c9d348
--- /dev/null
+++ b/testing/dash/dash.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/bin/dash'
+exit 0