aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/apk-tools/APKBUILD4
-rw-r--r--main/asterisk/APKBUILD4
-rw-r--r--main/haproxy/APKBUILD6
-rw-r--r--main/php/APKBUILD13
-rw-r--r--testing/altermime/APKBUILD39
-rw-r--r--testing/altermime/makefile-flags.patch21
-rw-r--r--testing/apache-mod-fcgid/APKBUILD34
-rw-r--r--testing/apache-mod-fcgid/mod_fcgid.conf9
-rw-r--r--testing/awesome/APKBUILD13
-rw-r--r--testing/awesome/cmake.patch37
-rw-r--r--testing/expect/APKBUILD2
-rw-r--r--testing/libshout/APKBUILD39
-rw-r--r--testing/memtest86+/APKBUILD4
-rw-r--r--testing/ngrep/APKBUILD6
-rw-r--r--testing/openvcp/APKBUILD13
-rw-r--r--testing/openxcap/APKBUILD14
-rw-r--r--testing/openxcap/openxcap.initd32
-rw-r--r--testing/perl-control-x10/APKBUILD4
-rw-r--r--testing/perl-php-serialization/APKBUILD2
-rw-r--r--testing/perl-sys-mmap/APKBUILD3
-rw-r--r--testing/qpage/APKBUILD10
21 files changed, 238 insertions, 71 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index b820e6643f..fe976bb2b1 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0.8
+pkgver=2.0.9
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
@@ -48,4 +48,4 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="6d6f1728aef13888a246b134b0231e3c apk-tools-2.0.8.tar.bz2"
+md5sums="3c9c114ffc01bf5752d28b3213484563 apk-tools-2.0.9.tar.bz2"
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 2ef74b6084..35e45c5415 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
-pkgver=1.8.2.4
+pkgver=1.8.3
pkgrel=0
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
@@ -156,7 +156,7 @@ sound_en() {
_move_dir var/lib/asterisk/sounds/en
}
-md5sums="b3cd5866ce73632a44c0ddb2f3b1ad1f asterisk-1.8.2.4.tar.gz
+md5sums="79964868c124a921e71fd568fbc9290f asterisk-1.8.3.tar.gz
b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
6e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
79e9634b5054bceb3b8dc246654bb243 400-bug-227.patch
diff --git a/main/haproxy/APKBUILD b/main/haproxy/APKBUILD
index 9f8355de76..38c43b1c4b 100644
--- a/main/haproxy/APKBUILD
+++ b/main/haproxy/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jeff Bilyk <jbilyk@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=haproxy
-pkgver=1.4.10
-pkgrel=1
+pkgver=1.4.11
+pkgrel=0
pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
url="http://haproxy.1wt.eu"
arch="all"
@@ -25,5 +25,5 @@ package() {
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="c35a7b7820d6da6c34cfd952805b4e85 haproxy-1.4.10.tar.gz
+md5sums="4f0638652d7800860838dc195da335d8 haproxy-1.4.11.tar.gz
cce88addaac6ee8065633b94c404300d haproxy.initd"
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 8ad19f27dc..b4146be14d 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -74,16 +74,25 @@ source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
$install
"
-_extdir="/usr/lib/php/20090626"
+_apiver="20090626"
+_extdir="/usr/lib/php/$_apiver"
+_srcdir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_srcdir"
# beat the pear installer into using xml.so
patch -p1 -i "$srcdir"/php-install-pear-xml.patch || return 1
patch -p1 -i "$srcdir"/php-uclibc.patch || return 1
# apply suhosin patch
patch -p1 -i "${srcdir}"/suhosin-patch-${_suhosinver}.patch || return 1
+
+ # safty check for api changes
+ local vapi=$(sed -n '/#define PHP_API_VERSION/{s/.* //;p}' main/php.h)
+ if [ "$vapi" != "$_apiver" ]; then
+ error "Upstreram API version is now $vapi. Expecting $_vapi"
+ return 1
+ fi
}
build() {
diff --git a/testing/altermime/APKBUILD b/testing/altermime/APKBUILD
new file mode 100644
index 0000000000..1e4667716b
--- /dev/null
+++ b/testing/altermime/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=altermime
+pkgver=0.3.10
+pkgrel=0
+pkgdesc="program alter mime-encoded mailpacks"
+url="http://www.pldaniels.com/altermime/"
+arch="all"
+license="Sendmail"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://www.pldaniels.com/altermime/altermime-$pkgver.tar.gz
+ makefile-flags.patch"
+
+_builddir="$srcdir"/altermime-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 altermime "$pkgdir"/usr/bin/altermime
+}
+
+md5sums="aaf0ad8029958a2dc6da3abb4dc178c2 altermime-0.3.10.tar.gz
+604775894fa4f8ddd9d44761ce2be2ea makefile-flags.patch"
diff --git a/testing/altermime/makefile-flags.patch b/testing/altermime/makefile-flags.patch
new file mode 100644
index 0000000000..71a399051e
--- /dev/null
+++ b/testing/altermime/makefile-flags.patch
@@ -0,0 +1,21 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -9,7 +9,8 @@
+ # opposite of a disclaimer.
+ #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS?=-Wall -Werror -g -I. -O2
++CFLAGS+=$(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +20,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} altermime.c ${OBJS} ${LDFLAGS} -o altermime
+
+
+ # Build Install
diff --git a/testing/apache-mod-fcgid/APKBUILD b/testing/apache-mod-fcgid/APKBUILD
new file mode 100644
index 0000000000..7f9c1d7c6e
--- /dev/null
+++ b/testing/apache-mod-fcgid/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer:
+pkgname=apache-mod-fcgid
+pkgver=2.3.6
+pkgrel=0
+pkgdesc="FastCGI module for Apache 2.2"
+url="http://httpd.apache.org/mod_fcgid/"
+arch="all"
+license="Apache"
+depends=
+makedepends="apache2-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://apache.cyberuse.com//httpd/mod_fcgid/mod_fcgid-$pkgver.tar.bz2
+ mod_fcgid.conf
+ "
+
+_builddir="$srcdir/mod_fcgid-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure.apxs || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir "$pkgdir"/etc/apache2/conf.d/ || return 1
+ install -m644 "$srcdir"/mod_fcgid.conf "$pkgdir"/etc/apache2/conf.d/ || return 1
+}
+
+md5sums="30ee138f3f0eb1c55303400748f128a2 mod_fcgid-2.3.6.tar.bz2
+df658a483cf016112d75bbd1d92d7fb0 mod_fcgid.conf"
diff --git a/testing/apache-mod-fcgid/mod_fcgid.conf b/testing/apache-mod-fcgid/mod_fcgid.conf
new file mode 100644
index 0000000000..01529b0683
--- /dev/null
+++ b/testing/apache-mod-fcgid/mod_fcgid.conf
@@ -0,0 +1,9 @@
+<IfModule mod_fcgid.c>
+ Alias /fcgi-bin/ "/usr/lib/fcgi-bin/"
+ <Location /fcgi-bin>
+ SetHandler fcgid-script
+ Options +ExecCGI
+ Order allow,deny
+ Allow from all
+ </Location>
+</IfModule>
diff --git a/testing/awesome/APKBUILD b/testing/awesome/APKBUILD
index 1b64807eb8..43531bf08d 100644
--- a/testing/awesome/APKBUILD
+++ b/testing/awesome/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=awesome
pkgver=3.4.9
-pkgrel=0
+pkgrel=1
pkgdesc="lua-configurable window manager framework"
url="http://awesome.naquadah.org/"
arch="all"
@@ -11,13 +11,15 @@ depends="imagemagick"
makedepends="lua-dev libxcb-dev pango-dev cairo-dev cmake gperf glib-dev imlib2-dev libxdg-basedir-dev libev-dev startup-notification-dev"
install=""
subpackages="$pkgname-doc"
-source="http://awesome.naquadah.org/download/${pkgname}-${pkgver}.tar.bz2"
+source="http://awesome.naquadah.org/download/${pkgname}-${pkgver}.tar.bz2
+ cmake.patch
+ "
_srcdir="${srcdir}/${pkgname}-${pkgver}"
_builddir="${srcdir}/build"
prepare() {
local i
- cd "$_builddir"
+ cd "$_srcdir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -37,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="a3e8f22fb4d17dd1cda90b354be84d6f awesome-3.4.9.tar.bz2"
+md5sums="a3e8f22fb4d17dd1cda90b354be84d6f awesome-3.4.9.tar.bz2
+3382b552d0519c8637c86b2e61f1e052 cmake.patch"
diff --git a/testing/awesome/cmake.patch b/testing/awesome/cmake.patch
new file mode 100644
index 0000000000..c2762374ed
--- /dev/null
+++ b/testing/awesome/cmake.patch
@@ -0,0 +1,37 @@
+commit 8b6adbffead83c9d77c493174d0f5b6a97f2a9e9
+Author: Thomas Moschny <thomas.moschny@gmx.de>
+Date: Mon Feb 21 17:58:04 2011 +0100
+
+ Normalize icon path names (fixes #869).
+
+ The elements in ${icon_sources}, as returned by file(GLOB ...) contain
+ double slashes, could be a bug in cmake. This causes building with
+ cmake 2.8.4 to fail, due to dependency problems lateron.
+
+ This patch works around the issue by normalizing all path names in
+ ${icon_sources} while appending them to ${ALL_ICONS}, thereby removing
+ the double slashes.
+
+ Signed-off-by: Uli Schlachter <psychon@znc.in>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64be9b9..472bec2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,14 +244,15 @@ endif()
+
+ # {{{ Theme icons
+ file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
+
+ foreach(icon ${icon_sources})
+ # Copy all icons to the build dir to simplify the following code.
+ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
+ # relative to ${BUILD_DIR}.
+ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
+ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
+ endforeach()
+
+ macro(a_icon_convert match replacement input)
diff --git a/testing/expect/APKBUILD b/testing/expect/APKBUILD
index ab37b50cf0..5ece406663 100644
--- a/testing/expect/APKBUILD
+++ b/testing/expect/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/expect/Expect/$pkgver/$pkgname$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname$pkgver
-
build() {
cd "$_builddir"
./configure --prefix=/usr
@@ -26,7 +25,6 @@ build() {
--disable-rpath
make || return 1
}
-
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
diff --git a/testing/libshout/APKBUILD b/testing/libshout/APKBUILD
new file mode 100644
index 0000000000..8f0e1f69fd
--- /dev/null
+++ b/testing/libshout/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=libshout
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="Library for accessing a shoutcast/icecast server"
+url="http://www.icecast.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="speex-dev libtheora-dev libvorbis-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ make LDFLAGS+=-lspeex || return 1
+
+}
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4f75fc9901c724b712c371c9a1e782d3 libshout-2.2.2.tar.gz"
diff --git a/testing/memtest86+/APKBUILD b/testing/memtest86+/APKBUILD
index cd8ec4eddb..cf00ff0ccb 100644
--- a/testing/memtest86+/APKBUILD
+++ b/testing/memtest86+/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname="memtest86+"
pkgver=4.20
-pkgrel=0
+pkgrel=1
pkgdesc="A tool for memory failure detection"
url="http://www.memtest.org"
-arch="noarch"
+arch="x86"
license="GPL"
depends=
depends_dev=
diff --git a/testing/ngrep/APKBUILD b/testing/ngrep/APKBUILD
index cdc056ddb5..67d6253d1e 100644
--- a/testing/ngrep/APKBUILD
+++ b/testing/ngrep/APKBUILD
@@ -8,14 +8,12 @@ url="http://ngrep.sourceforge.net/"
arch="all"
license="custom"
depends=
-depends_dev=
-makedepends="libpcap-dev"
+depends_dev="libpcap-dev"
+makedepends="$depends_dev"
install=""
subpackages=""
source="http://downloads.sourceforge.net/sourceforge/ngrep/$pkgname-$pkgver.tar.bz2"
-
_builddir="$srcdir"/$pkgname-$pkgver
-
build() {
cd "$_builddir"
./configure --prefix=/usr \
diff --git a/testing/openvcp/APKBUILD b/testing/openvcp/APKBUILD
index 72fdd6f581..ed2ab667f9 100644
--- a/testing/openvcp/APKBUILD
+++ b/testing/openvcp/APKBUILD
@@ -19,16 +19,6 @@ source="http://files.openvcp.org/$_pkgname-$_pkgver.tar.gz
_builddir="$srcdir"/$_pkgname-$_pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -36,7 +26,6 @@ build() {
--with-gnutls
make || return 1
}
-
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
@@ -44,4 +33,4 @@ package() {
}
md5sums="9c65d706133ea48553c90236997f1b8b openvcpd-0.5rc3.tar.gz
-db8efb9c086673fd2e3e2532294c7a2f openvcp.initd"
+08cef22e3abc5824133733e17aa4e607 openvcp.initd"
diff --git a/testing/openxcap/APKBUILD b/testing/openxcap/APKBUILD
index c216536810..812c6d16de 100644
--- a/testing/openxcap/APKBUILD
+++ b/testing/openxcap/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-
pkgname=openxcap
-pkgver=1.2.0
-pkgrel=4
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Open source fully featured XCAP server "
url="http://openxcap.org"
pkgusers="openxcap"
@@ -18,23 +17,18 @@ source="http://download.ag-projects.com/XCAP/$pkgname-$pkgver.tar.gz
config.ini
openxcap.initd
"
-
build() {
cd "$srcdir"/$pkgname-$pkgver
-
mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
-
python setup.py install --root="$pkgdir" || return 1
-
echo "/usr/lib/python2.6/site-packages/$pkgname-$pkgver-py2.6.egg" \
> "$pkgdir"/usr/lib/python2.6/site-packages/$pkgname.pth
-
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/config.ini \
"$pkgdir"/etc/openxcap/config.ini
install -d -o openxcap "$pkgdir"/var/run/openxcap
}
-md5sums="ec34570deee2019a1ebf9a012a476c26 openxcap-1.2.0.tar.gz
+md5sums="155b1ee85dd3217e5647ad3ac9f72cf6 openxcap-2.0.0.tar.gz
7a18872843586717eaf3879444cc13d2 config.ini
-5bebac590cb06b0eacaf040116bc354e openxcap.initd"
+0043d28e9e6e51e03661755d12080a28 openxcap.initd"
diff --git a/testing/openxcap/openxcap.initd b/testing/openxcap/openxcap.initd
index 69108afd8a..03286cce3d 100644
--- a/testing/openxcap/openxcap.initd
+++ b/testing/openxcap/openxcap.initd
@@ -1,23 +1,31 @@
#!/sbin/runscript
-#
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-daemon=/usr/bin/openxcap
-pidfile=/var/run/openxcap/openxcap.pid
+INSTALL_DIR="/usr/bin"
+RUNTIME_DIR="/var/run/openxcap"
+DEFAULTS="/etc/default/openxcap"
+SERVER="$INSTALL_DIR/openxcap"
+PID="$RUNTIME_DIR/openxcap.pid"
+OPTIONS=""
+NAME="openxcap"
+DESC="OpenXCAP server"
depend() {
- need net
- after firewall
+ need net
+ after firewall
}
start() {
- ebegin "Starting OpenXCAP Presence Server"
- start-stop-daemon --start --quiet --pidfile $pidfile --exec $daemon
- eend $?
+ ebegin "Starting $DESC: $NAME "
+ start-stop-daemon --start --quiet --pidfile $PID --exec $SERVER -- $OPTIONS
+ eend $?
}
-stop() {
- ebegin "Stopping OpenXCAP Presence Server"
- start-stop-daemon --stop --quiet --signal 15 --pidfile $pidfile
- eend $?
+stop () {
+ ebegin -n "Stopping $DESC: $NAME "
+ start-stop-daemon --stop --quiet --oknodo --signal 15 --pidfile $PID
+ eend $?
}
+exit 0
+
diff --git a/testing/perl-control-x10/APKBUILD b/testing/perl-control-x10/APKBUILD
index 616b0c16cd..10e91ee6cf 100644
--- a/testing/perl-control-x10/APKBUILD
+++ b/testing/perl-control-x10/APKBUILD
@@ -13,20 +13,16 @@ makedepends="perl-dev"
install=
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BB/BBIRTH/$_realname-$pkgver.tar.gz"
-
_builddir="$srcdir/$_realname-$pkgver"
-
build() {
cd $_builddir
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
make || return 1
}
-
package() {
cd $_builddir
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}
-
md5sums="b59c85e92eae2c14ffa63af7ac0a1d9a ControlX10-CM11-2.09.tar.gz"
diff --git a/testing/perl-php-serialization/APKBUILD b/testing/perl-php-serialization/APKBUILD
index 1fcf599cdc..9565691bb5 100644
--- a/testing/perl-php-serialization/APKBUILD
+++ b/testing/perl-php-serialization/APKBUILD
@@ -5,7 +5,7 @@ _realname=PHP-Serialization
pkgver=0.34
pkgrel=0
pkgdesc="Simple flexible means of converting the output of PHP's serialize() into the equivalent Perl memory structure, and vice versa."
-url="http://search.cpan.org/~bobtfish/PHP-Serialization-0.34/"
+url="http://search.cpan.org/~bobtfish/PHP-Serialization-$pkgver"
arch="noarch"
license="GPL PerlArtistic"
depends="perl"
diff --git a/testing/perl-sys-mmap/APKBUILD b/testing/perl-sys-mmap/APKBUILD
index e0906944ac..841f71035d 100644
--- a/testing/perl-sys-mmap/APKBUILD
+++ b/testing/perl-sys-mmap/APKBUILD
@@ -15,18 +15,15 @@ subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_realname-$pkgver.tar.gz"
_builddir="$srcdir/$_realname-$pkgver"
-
build() {
cd $_builddir
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
make || return 1
}
-
package() {
cd $_builddir
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}
-
md5sums="f3a1115b7632ca015532e8ca7134918b Sys-Mmap-0.14.tar.gz"
diff --git a/testing/qpage/APKBUILD b/testing/qpage/APKBUILD
index c93b542c2c..63adae631a 100644
--- a/testing/qpage/APKBUILD
+++ b/testing/qpage/APKBUILD
@@ -7,18 +7,16 @@ pkgdesc="Sends messages to an alphanumeric pager via TAP protocol."
url="http://www.qpage.org/"
arch="all"
license="Custom"
-depends=
+depends=""
depends_dev=
-makedepends=
+makedepends="$depends_dev"
install="$pkgname.pre-install $pkgname.post-install"
source="saveas-http://archive.debian.org/debian/pool/non-free/q/$pkgname/"$pkgname"_3.3final.orig.tar.gz/$pkgname-$pkgver.tar.gz
config.input
qpage.initd
qpage.patch
"
-
_builddir="$srcdir"/$pkgname-$pkgver
-
prepare() {
cd "$_builddir"
for i in $source; do
@@ -27,7 +25,6 @@ prepare() {
esac
done
}
-
build() {
cd "$_builddir"
cp -f "$srcdir"/config.input "$_builddir" || return 1
@@ -36,15 +33,14 @@ build() {
--localstatedir=/var
make || return 1
}
-
package() {
mkdir -p "$pkgdir"/usr/bin
mkdir -p "$pkgdir"/etc/qpage
install -m755 "$_builddir"/$pkgname "$pkgdir"/usr/bin/"$pkgname"
install -m644 -D "$_builddir"/example.cf "$pkgdir"/etc/qpage/qpage.conf.example
install -m644 -D "$_builddir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-
md5sums="eb98faaa51f89db68ecf7668f5294309 qpage-3.3.tar.gz
3ac8c6e2aede9e195eba2555eb3b4645 config.input
f439315da04ebdd1e1cc2840171d45d3 qpage.initd