aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/bogofilter/APKBUILD33
-rw-r--r--community/corebird/APKBUILD (renamed from testing/corebird/APKBUILD)0
-rw-r--r--community/corebird/disable-gst-check.diff (renamed from testing/corebird/disable-gst-check.diff)0
-rw-r--r--community/fbpanel/APKBUILD (renamed from testing/fbpanel/APKBUILD)0
-rw-r--r--community/gammu/APKBUILD (renamed from testing/gammu/APKBUILD)5
-rw-r--r--community/hermes/APKBUILD (renamed from testing/hermes/APKBUILD)0
-rw-r--r--community/hermes/Utils.cpp.patch (renamed from testing/hermes/Utils.cpp.patch)0
-rw-r--r--community/libdbi-drivers/APKBUILD (renamed from testing/libdbi-drivers/APKBUILD)0
-rw-r--r--community/luufs/APKBUILD (renamed from testing/luufs/APKBUILD)2
-rw-r--r--community/netsurf/APKBUILD (renamed from testing/netsurf/APKBUILD)0
-rw-r--r--community/netsurf/netsurf (renamed from testing/netsurf/netsurf)0
-rw-r--r--community/opencpn/APKBUILD (renamed from testing/opencpn/APKBUILD)0
-rw-r--r--community/opencpn/CMakeList.txt.patch (renamed from testing/opencpn/CMakeList.txt.patch)0
-rw-r--r--community/py-sensehat/APKBUILD (renamed from testing/py-sensehat/APKBUILD)0
-rw-r--r--community/rng-tools/APKBUILD (renamed from testing/rng-tools/APKBUILD)0
-rw-r--r--community/rng-tools/fix-textrels-on-PIC-x86.patch (renamed from testing/rng-tools/fix-textrels-on-PIC-x86.patch)0
-rw-r--r--community/rng-tools/rngd.confd (renamed from testing/rng-tools/rngd.confd)0
-rw-r--r--community/rng-tools/rngd.initd (renamed from testing/rng-tools/rngd.initd)0
-rw-r--r--community/volumeicon/APKBUILD (renamed from testing/volumeicon/APKBUILD)0
19 files changed, 37 insertions, 3 deletions
diff --git a/community/bogofilter/APKBUILD b/community/bogofilter/APKBUILD
new file mode 100644
index 0000000000..508c165196
--- /dev/null
+++ b/community/bogofilter/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=bogofilter
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="A Bayesian mail filter that classifies mail by statistical analysis of the message's header and content."
+url="http://bogofilter.sourceforge.net/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="sqlite-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+builddir=${srcdir}/${pkgname}-${pkgver}
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --with-included-gsl \
+ --with-database=sqlite3 || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=${pkgdir} install
+}
+
+md5sums="d0a5eebb3274b23ceabe766a6443a1c5 bogofilter-1.2.4.tar.bz2"
+sha256sums="e10287a58d135feaea26880ce7d4b9fa2841fb114a2154bf7da8da98aab0a6b4 bogofilter-1.2.4.tar.bz2"
+sha512sums="e8c0b6bcc14f12fbbb2752e697a6d9065e17abfca3f70045ce9fe668d01c1cfad4adaa35c81546ecdd3639b0c28f3f4776bb5ed4699f21e9e2a5b19ca33479db bogofilter-1.2.4.tar.bz2"
diff --git a/testing/corebird/APKBUILD b/community/corebird/APKBUILD
index e8c5c86463..e8c5c86463 100644
--- a/testing/corebird/APKBUILD
+++ b/community/corebird/APKBUILD
diff --git a/testing/corebird/disable-gst-check.diff b/community/corebird/disable-gst-check.diff
index a6b9d2cde2..a6b9d2cde2 100644
--- a/testing/corebird/disable-gst-check.diff
+++ b/community/corebird/disable-gst-check.diff
diff --git a/testing/fbpanel/APKBUILD b/community/fbpanel/APKBUILD
index 0cae568507..0cae568507 100644
--- a/testing/fbpanel/APKBUILD
+++ b/community/fbpanel/APKBUILD
diff --git a/testing/gammu/APKBUILD b/community/gammu/APKBUILD
index ec0c8d8274..ac77fe4615 100644
--- a/testing/gammu/APKBUILD
+++ b/community/gammu/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
-# Maintainer:
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=gammu
pkgver=1.33.0
pkgrel=0
@@ -10,7 +10,8 @@ license="GPLv2+"
depends="dialog bluez"
depends_dev=""
makedepends="$depends_dev unixodbc-dev libdbi-dev postgresql-dev
- bluez-dev mysql-dev libusb-dev curl-dev cmake doxygen linux-headers"
+ bluez-dev mysql-dev libusb-dev curl-dev cmake doxygen linux-headers
+ python2-dev"
install=""
subpackages="$pkgname-smsd:_smsd $pkgname-doc $pkgname-dev py-$pkgname:_py
$pkgname-libs"
diff --git a/testing/hermes/APKBUILD b/community/hermes/APKBUILD
index f57a03428f..f57a03428f 100644
--- a/testing/hermes/APKBUILD
+++ b/community/hermes/APKBUILD
diff --git a/testing/hermes/Utils.cpp.patch b/community/hermes/Utils.cpp.patch
index d5b5c16354..d5b5c16354 100644
--- a/testing/hermes/Utils.cpp.patch
+++ b/community/hermes/Utils.cpp.patch
diff --git a/testing/libdbi-drivers/APKBUILD b/community/libdbi-drivers/APKBUILD
index b64ebfaf4e..b64ebfaf4e 100644
--- a/testing/libdbi-drivers/APKBUILD
+++ b/community/libdbi-drivers/APKBUILD
diff --git a/testing/luufs/APKBUILD b/community/luufs/APKBUILD
index 7d9299f5d5..93dcb490d8 100644
--- a/testing/luufs/APKBUILD
+++ b/community/luufs/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
-# Maintainer:
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=luufs
pkgver=05012015
pkgrel=0
diff --git a/testing/netsurf/APKBUILD b/community/netsurf/APKBUILD
index 5187dc5c52..5187dc5c52 100644
--- a/testing/netsurf/APKBUILD
+++ b/community/netsurf/APKBUILD
diff --git a/testing/netsurf/netsurf b/community/netsurf/netsurf
index 1a7d693e21..1a7d693e21 100644
--- a/testing/netsurf/netsurf
+++ b/community/netsurf/netsurf
diff --git a/testing/opencpn/APKBUILD b/community/opencpn/APKBUILD
index db6d4bb385..db6d4bb385 100644
--- a/testing/opencpn/APKBUILD
+++ b/community/opencpn/APKBUILD
diff --git a/testing/opencpn/CMakeList.txt.patch b/community/opencpn/CMakeList.txt.patch
index 8a1341d424..8a1341d424 100644
--- a/testing/opencpn/CMakeList.txt.patch
+++ b/community/opencpn/CMakeList.txt.patch
diff --git a/testing/py-sensehat/APKBUILD b/community/py-sensehat/APKBUILD
index bfad9a50a7..bfad9a50a7 100644
--- a/testing/py-sensehat/APKBUILD
+++ b/community/py-sensehat/APKBUILD
diff --git a/testing/rng-tools/APKBUILD b/community/rng-tools/APKBUILD
index 83d0de3d84..83d0de3d84 100644
--- a/testing/rng-tools/APKBUILD
+++ b/community/rng-tools/APKBUILD
diff --git a/testing/rng-tools/fix-textrels-on-PIC-x86.patch b/community/rng-tools/fix-textrels-on-PIC-x86.patch
index 88d0a7f905..88d0a7f905 100644
--- a/testing/rng-tools/fix-textrels-on-PIC-x86.patch
+++ b/community/rng-tools/fix-textrels-on-PIC-x86.patch
diff --git a/testing/rng-tools/rngd.confd b/community/rng-tools/rngd.confd
index c065e7e3b9..c065e7e3b9 100644
--- a/testing/rng-tools/rngd.confd
+++ b/community/rng-tools/rngd.confd
diff --git a/testing/rng-tools/rngd.initd b/community/rng-tools/rngd.initd
index b91412ddf8..b91412ddf8 100644
--- a/testing/rng-tools/rngd.initd
+++ b/community/rng-tools/rngd.initd
diff --git a/testing/volumeicon/APKBUILD b/community/volumeicon/APKBUILD
index 15163466d2..15163466d2 100644
--- a/testing/volumeicon/APKBUILD
+++ b/community/volumeicon/APKBUILD