aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py-py/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/py-py/APKBUILD b/community/py-py/APKBUILD
index 779cd95203..3525021adc 100644
--- a/community/py-py/APKBUILD
+++ b/community/py-py/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-py
_pkgname=py
-pkgver=1.4.34
+pkgver=1.5.3
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="http://pytest.org"
@@ -16,10 +16,17 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
package() {
mkdir -p "$pkgdir"
}
@@ -43,4 +50,4 @@ _py3() {
_py python3
}
-sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py-1.4.34.tar.gz"
+sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py-1.5.3.tar.gz"