aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/dnsmasq/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index 54886b328f..5db1374063 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -22,6 +22,13 @@ build() {
make PREFIX=/usr CFLAGS="$CFLAGS" all || return 1
}
+# dnsmasq doesn't provide any test suite (shame on them!), so just check that
+# the binary isn't totally broken...
+check() {
+ cd "$builddir"
+ ./src/dnsmasq --help >/dev/null
+}
+
package() {
cd "$builddir"