aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/xdesktop/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/community/xdesktop/APKBUILD b/community/xdesktop/APKBUILD
index 45e675723b..75137f3ff4 100644
--- a/community/xdesktop/APKBUILD
+++ b/community/xdesktop/APKBUILD
@@ -7,24 +7,19 @@ pkgdesc="output and change X virtual desktop"
url="https://github.com/onodera-punpun/xdesktop"
arch="all"
license="unlicense"
-depends=""
depends_dev="xcb-util-wm-dev"
makedepends="$depends_dev"
-install=""
-subpackages=""
-source="saveas-https://github.com/onodera-punpun/$pkgname/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/onodera-punpun/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
-md5sums="fbc59a158d93dcee518bd6298a2c3530 xdesktop-0.3.tar.gz"
-sha256sums="b2c9cd6aaae3b13c4fd8f61799b12454387be838df9078db6faf14dbfaef01ca xdesktop-0.3.tar.gz"
sha512sums="125d880c0d2af5c847b74caf5fc51f32d597dc00f25dc334fa5a2664438b248da5989d3f4df2bbd7c5998511cdcf2144625ebc0653ad481dd88378551a7ae529 xdesktop-0.3.tar.gz"