aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/duo_unix/APKBUILD12
-rw-r--r--community/duo_unix/libressl.patch7
2 files changed, 13 insertions, 6 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index aad6fe6ff8..82434fcbae 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
-pkgver=1.9.19
-pkgrel=3
+pkgver=1.9.21
+pkgrel=0
pkgdesc="duosecurity.com two-factor authentication"
url="https://duo.com/support/documentation/duounix"
arch="all"
@@ -13,7 +13,8 @@ makedepends="$depends_dev"
install=""
options="suid"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz"
+source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz
+ libressl.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -44,6 +45,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="2df21908cb1f8b58823291b4673289cd duo_unix-1.9.19.tar.gz"
-sha256sums="2d23f9700f091da1c9113b45919203b37fac6392a9e24a666c7b0269a7571b0a duo_unix-1.9.19.tar.gz"
-sha512sums="daefc3bddf685c90fc42ca91fc961dcdc0f48c296dfb393e0baccc083874d7214914c0faa840d3c9b6a9f454e4e2122ebd312c33319c56c19e30374a89bd03cf duo_unix-1.9.19.tar.gz"
+sha512sums="8caf1b9dea266662d2e221fa120be1989622828ba346f874f77090ed0f91431e250da2cfe335bc9ff0b8a6336a20458851e715342c5f90151cf4514e76b04fa9 duo_unix-1.9.21.tar.gz
+4e078c876baaedeffb4b8790f713e4bd486a71ef8a8cccade9262ea56dc7ada4ec65f467850d6d2311899b4d93afc95e21d0b585a446a3ca0a36498ada37ec67 libressl.patch"
diff --git a/community/duo_unix/libressl.patch b/community/duo_unix/libressl.patch
new file mode 100644
index 0000000000..57c5f2f95d
--- /dev/null
+++ b/community/duo_unix/libressl.patch
@@ -0,0 +1,7 @@
+diff --git a/lib/https.c b/lib/https.c
+index b64e03a..b900924 100644
+--- a/lib/https.c
++++ b/lib/https.c
+@@ -356 +356 @@ _establish_connection(struct https_request * const req,
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)