aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/fftw/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/fftw/APKBUILD b/main/fftw/APKBUILD
index ca0f27c4cf..d102953694 100644
--- a/main/fftw/APKBUILD
+++ b/main/fftw/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=fftw
pkgver=3.3.6p2
-pkgrel=0
+pkgrel=1
pkgdesc="fastest fourier transform in the west"
url="http://www.fftw.org/"
-license="GPL"
+license="GPL-2.0+"
makedepends="texinfo"
# order of the libs split functions are important because of lib naming
subpackages="$pkgname-dev $pkgname-doc $pkgname-single-libs:single
@@ -57,6 +57,13 @@ build() {
done
}
+check() {
+ for i in $_precision; do
+ cd "$srcdir"/$i
+ make check
+ done
+}
+
package() {
for i in $_precision; do
cd "$srcdir"/$i