aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/bitcoin/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/bitcoin/APKBUILD b/testing/bitcoin/APKBUILD
index 335ddb6836..33738e714d 100644
--- a/testing/bitcoin/APKBUILD
+++ b/testing/bitcoin/APKBUILD
@@ -35,6 +35,10 @@ prepare() {
build() {
cd "$_builddir"
+ # we need to set BOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT after
+ # boost 1.58.0
+ # http://www.boost.org/doc/libs/1_58_0/doc/html/boost/get_idp295310448.html
+ CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1" \
./configure \
--build=$CBUILD \
--host=$CHOST \