aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--core/alpine-baselayout/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/core/alpine-baselayout/APKBUILD b/core/alpine-baselayout/APKBUILD
index 4a10d3bcfd..4b1dd4b403 100644
--- a/core/alpine-baselayout/APKBUILD
+++ b/core/alpine-baselayout/APKBUILD
@@ -1,29 +1,28 @@
pkgname=alpine-baselayout
-pkgver=2009.01.08
+pkgver=2.0_alpha2
pkgrel=0
pkgdesc="Alpine base dir structure and init scripts"
url=http://dev.alpinelinux.org/alpine/alpine-baselayout
depends="uclibc"
-#source="http://dev.alpinelinux.org/alpine/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://dev.alpinelinux.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
license=GPL-2
_gitname=$pkgname
_gitroot=git://dev.alpinelinux.org/$_gitname
build() {
- cd "$srcdir"
- msg "Connecting to GIT server..."
+ cd "$srcdir"/$pkgname
+# msg "Connecting to GIT server..."
+# if [ -d $_gitname ]; then
+# cd $_gitname && git pull
+# else
+# git clone $_gitroot
+# fi
- if [ -d $_gitname ]; then
- cd $_gitname && git pull
- else
- git clone $_gitroot
- fi
+# cd $srcdir/$_gitname
+# git checkout -b $pkgver @{`echo $pkgver | tr . -`} || return 1
- cd $srcdir/$_gitname
- git checkout -b $pkgver @{`echo $pkgver | tr . -`} || return 1
-
- make clean
make
make install PREFIX= DESTDIR="$pkgdir" || return 1
}
+md5sums="b8fe6a726391cee413e791c8d66ab510 alpine-baselayout-2.0_alpha2.tar.bz2"