aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/freeswitch/APKBUILD8
-rwxr-xr-xmain/freeswitch/freeswitch.pre-install3
2 files changed, 6 insertions, 5 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 241b706418..22d59f38b8 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -31,7 +31,8 @@ build() {
--sysconfdir=/etc/freeswitch \
--with-modinstdir=/usr/lib/freeswitch \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --without-rundir
# check how/when parallel builds are fixed here:
# http://jira.freeswitch.org/browse/FSBUILD-6
@@ -51,6 +52,7 @@ build() {
package(){
cd "$srcdir/$pkgname-$pkgver"
make -j1 DESTDIR="$pkgdir" install
+ mkdir "$pkgdir"/var/run/freeswitch
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
@@ -60,5 +62,5 @@ c05f2356be159e99b3845f5260a33599 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
dd3a6535c54fc6ed8399d6bb57d88369 freeswitch.initd
c0d7ad55063b1f62c9a2fcfa37b2fc0a freeswitch.post-install
-a34305ba1f8a8e7e6dbb9c678cc442b9 freeswitch.pre-install
+661e2dff4022522b95c875f2f88aa66a freeswitch.pre-install
a7188703019a74fd7f128d165b3ecf42 freeswitch.post-deinstall"
diff --git a/main/freeswitch/freeswitch.pre-install b/main/freeswitch/freeswitch.pre-install
index b8065b52b6..23756f31df 100755
--- a/main/freeswitch/freeswitch.pre-install
+++ b/main/freeswitch/freeswitch.pre-install
@@ -1,4 +1,3 @@
#!/bin/sh
-adduser -h /dev/null -s /bin/false -D freeswitch 2>/dev/null
-mkdir /var/run/freeswitch
+adduser -H /var/run/freeswitch -s /bin/false -D freeswitch 2>/dev/null