aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/alpine-baselayout/APKBUILD5
-rw-r--r--main/alpine-baselayout/alpine-baselayout.post-upgrade35
-rw-r--r--main/usb-modeswitch/APKBUILD (renamed from testing/usb-modeswitch/APKBUILD)0
-rw-r--r--main/usb-modeswitch/Makefile.patch (renamed from testing/usb-modeswitch/Makefile.patch)0
-rw-r--r--main/usb-modeswitch/usb_modeswitch.setup (renamed from testing/usb-modeswitch/usb_modeswitch.setup)0
-rw-r--r--testing/libtorrent/APKBUILD31
-rw-r--r--testing/rtorrent/APKBUILD38
7 files changed, 106 insertions, 3 deletions
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index 15f61d55d6..aaffe4400e 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-baselayout
pkgver=2.2.0
-pkgrel=0
+pkgrel=3
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
depends=
options="!fhs"
-install="$pkgname.pre-upgrade"
+install="$pkgname.pre-upgrade $pkgname.post-upgrade"
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
0001-blacklist-viafb-and-e_powersaver.patch
"
@@ -27,7 +27,6 @@ build() {
package() {
cd "$_builddir"
make install PREFIX= DESTDIR="$pkgdir" || return 1
- mkdir "$pkgdir"/run
rm -rf "$pkgdir"/etc/issue "$pkgdir"/usr/share/udhcpc \
"$pkgdir"/etc/init.d/vlan
}
diff --git a/main/alpine-baselayout/alpine-baselayout.post-upgrade b/main/alpine-baselayout/alpine-baselayout.post-upgrade
new file mode 100644
index 0000000000..8edfb73d71
--- /dev/null
+++ b/main/alpine-baselayout/alpine-baselayout.post-upgrade
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+create_vserver_startstop() {
+ cat <<__EOF__
+#!/bin/sh
+
+# This file is for compatibility
+case \${0##*/} in
+rcL)
+ RUNLEVEL=1 /sbin/rc sysinit || exit 1
+ /sbin/rc boot || exit 1
+ /sbin/rc \${1:-default}
+ exit 0
+ ;;
+rcK)
+ /sbin/rc shutdown
+ ;;
+esac
+
+__EOF__
+}
+
+# create compat start/stop scripts for vserver guests
+if [ "$(/sbin/rc --sys)" = "VSERVER" ]; then
+ # create rcL and rcK
+ if ! [ -e /etc/init.d/rcL ]; then
+ create_vserver_startstop > /etc/init.d/rcL
+ chmod +x /etc/init.d/rcL
+ fi
+ if ! [ -e /etc/init.d/rcK ]; then
+ ln -s rcL /etc/init.d/rcK
+ fi
+fi
+
+exit 0
diff --git a/testing/usb-modeswitch/APKBUILD b/main/usb-modeswitch/APKBUILD
index e5e86a513c..e5e86a513c 100644
--- a/testing/usb-modeswitch/APKBUILD
+++ b/main/usb-modeswitch/APKBUILD
diff --git a/testing/usb-modeswitch/Makefile.patch b/main/usb-modeswitch/Makefile.patch
index d7f526aa1e..d7f526aa1e 100644
--- a/testing/usb-modeswitch/Makefile.patch
+++ b/main/usb-modeswitch/Makefile.patch
diff --git a/testing/usb-modeswitch/usb_modeswitch.setup b/main/usb-modeswitch/usb_modeswitch.setup
index a86ef2a60a..a86ef2a60a 100644
--- a/testing/usb-modeswitch/usb_modeswitch.setup
+++ b/main/usb-modeswitch/usb_modeswitch.setup
diff --git a/testing/libtorrent/APKBUILD b/testing/libtorrent/APKBUILD
new file mode 100644
index 0000000000..06865bc7e5
--- /dev/null
+++ b/testing/libtorrent/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=libtorrent
+pkgver=0.12.9
+pkgrel=1
+pkgdesc='BitTorrent library written in C++'
+url='http://libtorrent.rakshasa.no/'
+arch='all'
+license='GPL'
+makedepends='libsigc++-dev openssl-dev'
+subpackages="$pkgname-dev"
+options='libtool'
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b128bbd324f03eb42ef5060080f87548 libtorrent-0.12.9.tar.gz"
diff --git a/testing/rtorrent/APKBUILD b/testing/rtorrent/APKBUILD
new file mode 100644
index 0000000000..01c6162720
--- /dev/null
+++ b/testing/rtorrent/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=rtorrent
+pkgver=0.8.9
+pkgrel=1
+pkgdesc='Ncurses BitTorrent client based on libTorrent'
+url='http://libtorrent.rakshasa.no/'
+license='GPL'
+arch='all'
+makedepends='libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev'
+subpackages="$pkgname-doc"
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export LDFLAGS="${LDFLAGS} -lpthread"
+ ./configure \
+ --prefix=/usr \
+ --enable-debug \
+ --with-xmlrpc-c \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D doc/faq.xml "${pkgdir}"/usr/share/doc/rtorrent/faq.xml \
+ || return 1
+ install -D doc/rtorrent.1 "${pkgdir}"/usr/share/man/man1/rtorrent.1 \
+ || return 1
+ install -D doc/rtorrent.rc \
+ "${pkgdir}"/usr/share/doc/rtorrent/rtorrent.rc || return 1
+}
+
+md5sums="629247636cb1210663b52dadbd040a6c rtorrent-0.8.9.tar.gz"