aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/m4/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index 7216a43b7a..cf37f2b336 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -12,8 +12,12 @@ source="ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
"
_builddir="$srcdir"/$pkgname-$pkgver
+
prepare() {
cd "$_builddir"
+ # fix eglibc-2.16+ build issue
+ sed -i -e '/gets is a/d' \
+ lib/stdio.in.h || return 1
}
build() {