aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/sqlite/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/main/sqlite/APKBUILD b/main/sqlite/APKBUILD
index 20f87b68fd..32ccb68885 100644
--- a/main/sqlite/APKBUILD
+++ b/main/sqlite/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=sqlite
-pkgver=3.7.12.1
+pkgver=3.7.13
_a=${pkgver%%.*}
_b=${pkgver#${_a}.}
_b=${_b%%.*}
@@ -16,7 +16,7 @@ esac
[ $_d -lt 10 ] && _d=0$_d
_ver=${_a}${_b}${_c}${_d}
-pkgrel=2
+pkgrel=0
pkgdesc="A C library that implements an SQL database engine"
url="http://www.sqlite.org/"
arch="all"
@@ -39,12 +39,9 @@ build() {
export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_ENABLE_RTREE=1 -Iext/fts3"
./configure --prefix=/usr \
--enable-threadsafe \
- --enable-load-extension \
- --enable-threads-override-locks \
- --enable-cross-thread-connections \
--disable-static \
- --disable-tcl \
--enable-readline \
+ --enable-dynamic-extensions \
|| return 1
# rpath removal
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@@ -86,5 +83,5 @@ libs() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
}
-md5sums="eb7bbd258913518ad30971ea7ecb0ca9 sqlite-autoconf-3071201.tar.gz
+md5sums="c97df403e8a3d5b67bb408fcd6aabd8e sqlite-autoconf-3071300.tar.gz
c1cdbc5544034d9012e421e75a5e4890 license.txt"