aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-funcparserlib/APKBUILD47
-rw-r--r--testing/py3-funcparserlib/APKBUILD27
2 files changed, 27 insertions, 47 deletions
diff --git a/testing/py-funcparserlib/APKBUILD b/testing/py-funcparserlib/APKBUILD
deleted file mode 100644
index 59b5342317..0000000000
--- a/testing/py-funcparserlib/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-funcparserlib
-_pkgname=funcparserlib
-pkgver=0.3.6
-pkgrel=3
-pkgdesc="Recursive descent parsing library based on functional combinators"
-url="https://github.com/vlasovskikh/funcparserlib"
-arch="noarch"
-license="MIT"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-md5sums="3aba546bdad5d0826596910551ce37c0 funcparserlib-0.3.6.tar.gz"
-sha256sums="b7992eac1a3eb97b3d91faa342bfda0729e990bd8a43774c1592c091e563c91d funcparserlib-0.3.6.tar.gz"
-sha512sums="efa52f788aa902b099660cb8bc60a025085a8c383e52bd0824a0c3ae28a6c13804a0659de0c80b4dcd839ee70491805d4eecda6cea221e35c3750ec569098c24 funcparserlib-0.3.6.tar.gz"
diff --git a/testing/py3-funcparserlib/APKBUILD b/testing/py3-funcparserlib/APKBUILD
new file mode 100644
index 0000000000..ce65dc2fdd
--- /dev/null
+++ b/testing/py3-funcparserlib/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-funcparserlib
+_pkgname=funcparserlib
+pkgver=0.3.6
+pkgrel=3
+pkgdesc="Recursive descent parsing library based on functional combinators"
+url="https://github.com/vlasovskikh/funcparserlib"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-funcparserlib" # for backwards compatibility
+provides="py-funcparserlib" # for backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="efa52f788aa902b099660cb8bc60a025085a8c383e52bd0824a0c3ae28a6c13804a0659de0c80b4dcd839ee70491805d4eecda6cea221e35c3750ec569098c24 funcparserlib-0.3.6.tar.gz"