aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ktorrent/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/ktorrent/APKBUILD b/testing/ktorrent/APKBUILD
new file mode 100644
index 0000000000..578f1aedec
--- /dev/null
+++ b/testing/ktorrent/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ktorrent
+pkgver=5.1.1
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/internet/org.kde.ktorrent"
+pkgdesc="A powerful BitTorrent client for KDE"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev kconfigwidgets-dev
+ kcoreaddons-dev kcrash-dev kdbusaddons-dev ki18n-dev kiconthemes-dev
+ kio-dev knotifications-dev knotifyconfig-dev kcmutils-dev kparts-dev
+ solid-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdoctools-dev
+ libktorrent-dev boost-dev ktextwidgets-dev karchive-dev kitemviews-dev
+ kross-dev kplotting-dev syndication-dev kdewebkit-dev kdnssd-dev
+ kcompletion-dev plasma-workspace-dev taglib-dev phonon-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/ktorrent/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ # The infowidget plugin is disabled due to an incompatibility with musl
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_INFOWIDGET_PLUGIN=FALSE
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="bbe744853018380e30efc6ef95916a9b6f0ebec812d70d7970e5e7183d860d147b0693dd0107b146a5987aa27f30cd335fad73c8967839d53eee1c5b63a53c06 ktorrent-5.1.1.tar.xz"