aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ronn/APKBUILD4
-rw-r--r--community/ruby-concurrent-ruby/APKBUILD6
-rw-r--r--community/ruby-diff-lcs/APKBUILD4
-rw-r--r--community/ruby-enum/APKBUILD4
-rw-r--r--community/ruby-ffi/APKBUILD4
-rw-r--r--community/ruby-hpricot/APKBUILD4
-rw-r--r--community/ruby-i18n/APKBUILD4
-rw-r--r--community/ruby-mathematical/APKBUILD4
-rw-r--r--community/ruby-mini_portile2/APKBUILD4
-rw-r--r--community/ruby-multi_json/APKBUILD4
-rw-r--r--community/ruby-mustache/APKBUILD4
-rw-r--r--community/ruby-nokogiri/APKBUILD4
-rw-r--r--community/ruby-pygments/APKBUILD4
-rw-r--r--community/ruby-rake-compiler/APKBUILD4
-rw-r--r--community/ruby-rdiscount/APKBUILD4
-rw-r--r--community/ruby-rmagick/APKBUILD4
-rw-r--r--community/ruby-rspec-core/APKBUILD4
-rw-r--r--community/ruby-rspec-expectations/APKBUILD4
-rw-r--r--community/ruby-rspec-mocks/APKBUILD4
-rw-r--r--community/ruby-rspec-support/APKBUILD4
-rw-r--r--community/ruby-rspec/APKBUILD4
-rw-r--r--community/ruby-timecop/APKBUILD4
22 files changed, 45 insertions, 45 deletions
diff --git a/community/ronn/APKBUILD b/community/ronn/APKBUILD
index e2c7a034ba..0d57eeaf7a 100644
--- a/community/ronn/APKBUILD
+++ b/community/ronn/APKBUILD
@@ -4,7 +4,7 @@
pkgname=ronn
_gemname=$pkgname
pkgver=0.7.3
-pkgrel=0
+pkgrel=1
pkgdesc="Convert Markdown files to manpages"
url="https://rtomayko.github.io/ronn/"
arch="noarch"
@@ -26,7 +26,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
cd "$builddir"
diff --git a/community/ruby-concurrent-ruby/APKBUILD b/community/ruby-concurrent-ruby/APKBUILD
index 8ef9c993e9..66c28c4e46 100644
--- a/community/ruby-concurrent-ruby/APKBUILD
+++ b/community/ruby-concurrent-ruby/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-concurrent-ruby
_gemname=${pkgname#ruby-}
pkgver=1.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Modern concurrency tools for Ruby"
url="http://www.concurrent-ruby.com"
arch="all"
@@ -43,7 +43,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
@@ -66,7 +66,7 @@ ext() {
pkgdesc="$pkgdesc (C extension)"
depends="$pkgname=$pkgver-r$pkgrel"
- local gemdir="$subpkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$subpkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
diff --git a/community/ruby-diff-lcs/APKBUILD b/community/ruby-diff-lcs/APKBUILD
index ca7ab10329..91161d4abe 100644
--- a/community/ruby-diff-lcs/APKBUILD
+++ b/community/ruby-diff-lcs/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-diff-lcs
_gemname=${pkgname#ruby-}
pkgver=1.3
-pkgrel=0
+pkgrel=1
pkgdesc="Generate difference sets between Ruby sequences"
url="http://halostatue.github.io/diff-lcs/"
arch="noarch"
@@ -20,7 +20,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
cd "$builddir"
diff --git a/community/ruby-enum/APKBUILD b/community/ruby-enum/APKBUILD
index 1e6f1a3b1b..99c6ff664d 100644
--- a/community/ruby-enum/APKBUILD
+++ b/community/ruby-enum/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-enum
_gemname=$pkgname
pkgver=0.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="A handy way to define enums in Ruby"
url="https://github.com/dblock/ruby-enum"
arch="noarch"
@@ -24,7 +24,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
cd "$builddir"
diff --git a/community/ruby-ffi/APKBUILD b/community/ruby-ffi/APKBUILD
index cb003f29e4..5d1eb3e611 100644
--- a/community/ruby-ffi/APKBUILD
+++ b/community/ruby-ffi/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-ffi
_gemname=ffi
pkgver=1.9.18
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby FFI library"
url="https://github.com/ffi/ffi"
arch="all"
@@ -42,7 +42,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local carch
case "$CARCH" in
diff --git a/community/ruby-hpricot/APKBUILD b/community/ruby-hpricot/APKBUILD
index e176d91577..a776c698e4 100644
--- a/community/ruby-hpricot/APKBUILD
+++ b/community/ruby-hpricot/APKBUILD
@@ -4,7 +4,7 @@
pkgname=ruby-hpricot
_gemname=hpricot
pkgver=0.8.6
-pkgrel=0
+pkgrel=1
pkgdesc="A swift, liberal HTML parser with a fantastic library (legacy)"
url="https://github.com/hpricot/hpricot"
arch="all"
@@ -36,7 +36,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
mkdir -p "$gemdir"
diff --git a/community/ruby-i18n/APKBUILD b/community/ruby-i18n/APKBUILD
index ca5ed3d549..0a33c463d9 100644
--- a/community/ruby-i18n/APKBUILD
+++ b/community/ruby-i18n/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-i18n
_gemname=${pkgname#ruby-}
pkgver=0.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="New wave Internationalization support for Ruby"
url="https://github.com/svenfuchs/i18n"
arch="noarch"
@@ -19,7 +19,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-mathematical/APKBUILD b/community/ruby-mathematical/APKBUILD
index 7e9eee86ca..58e7dbcd74 100644
--- a/community/ruby-mathematical/APKBUILD
+++ b/community/ruby-mathematical/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-mathematical
_gemname=${pkgname#ruby-}
pkgver=1.6.11
-pkgrel=0
+pkgrel=1
pkgdesc="Convert mathematical equations to SVGs, PNGs, or MathML"
url="https://www.gjtorikian.com/mathematical/"
arch="all"
@@ -58,7 +58,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
mkdir -p "$gemdir"
diff --git a/community/ruby-mini_portile2/APKBUILD b/community/ruby-mini_portile2/APKBUILD
index 74b8454a36..6868417d28 100644
--- a/community/ruby-mini_portile2/APKBUILD
+++ b/community/ruby-mini_portile2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-mini_portile2
_gemname=${pkgname#ruby-}
pkgver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Simplistic port-like solution for developers"
url="https://github.com/flavorjones/mini_portile"
arch="noarch"
@@ -13,7 +13,7 @@ source="https://rubygems.org/downloads/$_gemname-$pkgver.gem"
options="!check" # FIXME
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
gem install \
diff --git a/community/ruby-multi_json/APKBUILD b/community/ruby-multi_json/APKBUILD
index 72d27231b6..90175957cc 100644
--- a/community/ruby-multi_json/APKBUILD
+++ b/community/ruby-multi_json/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ruby-multi_json
_gemname=${pkgname#ruby-}
pkgver=1.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="A gem to provide easy switching between different JSON backends"
url="https://rubygems.org/gems/multi_json"
arch="noarch"
@@ -24,7 +24,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
cd "$builddir"
diff --git a/community/ruby-mustache/APKBUILD b/community/ruby-mustache/APKBUILD
index d312c31fcc..0246715b22 100644
--- a/community/ruby-mustache/APKBUILD
+++ b/community/ruby-mustache/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-mustache
_gemname=mustache
pkgver=1.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Logic-less Ruby templates"
url="https://mustache.github.io/"
arch="noarch"
@@ -25,7 +25,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
local geminstdir="$gemdir/gems/$_gemname-$pkgver"
cd "$builddir"
diff --git a/community/ruby-nokogiri/APKBUILD b/community/ruby-nokogiri/APKBUILD
index 771e10622d..5761c61239 100644
--- a/community/ruby-nokogiri/APKBUILD
+++ b/community/ruby-nokogiri/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-nokogiri
_gemname=${pkgname#ruby-}
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="An HTML, XML, SAX, and Reader parser"
url="http://nokogiri.org/"
arch="all"
@@ -64,7 +64,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
diff --git a/community/ruby-pygments/APKBUILD b/community/ruby-pygments/APKBUILD
index bbefc068bf..09381020b3 100644
--- a/community/ruby-pygments/APKBUILD
+++ b/community/ruby-pygments/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-pygments
_gemname=pygments.rb
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Pygments syntax highlighting in Ruby"
url="https://github.com/tmm1/pygments.rb"
arch="noarch"
@@ -40,7 +40,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-rake-compiler/APKBUILD b/community/ruby-rake-compiler/APKBUILD
index 26f69b3af2..26df7aa095 100644
--- a/community/ruby-rake-compiler/APKBUILD
+++ b/community/ruby-rake-compiler/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rake-compiler
_gemname=${pkgname#ruby-}
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Provide a standard and simplified way to build and package Ruby extensions"
url="https://github.com/rake-compiler/rake-compiler"
arch="noarch"
@@ -26,7 +26,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
diff --git a/community/ruby-rdiscount/APKBUILD b/community/ruby-rdiscount/APKBUILD
index 2bc652f113..8add49f2fd 100644
--- a/community/ruby-rdiscount/APKBUILD
+++ b/community/ruby-rdiscount/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rdiscount
_gemname=rdiscount
pkgver=2.2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fast Implementation of Gruber's Markdown in C"
url="http://dafoster.net/projects/rdiscount/"
arch="all"
@@ -32,7 +32,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
mkdir -p "$gemdir"
diff --git a/community/ruby-rmagick/APKBUILD b/community/ruby-rmagick/APKBUILD
index 2341d47ace..5ef9c35abc 100644
--- a/community/ruby-rmagick/APKBUILD
+++ b/community/ruby-rmagick/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ruby-rmagick
_gemname=rmagick
pkgver=2.16.0
_pkgver=${pkgver//./-}
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby bindings for ImageMagick"
url="https://rmagick.github.io/"
arch="all"
@@ -35,7 +35,7 @@ check() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"/dist
mkdir -p "$gemdir"
diff --git a/community/ruby-rspec-core/APKBUILD b/community/ruby-rspec-core/APKBUILD
index c7539aab9f..44a12e36bb 100644
--- a/community/ruby-rspec-core/APKBUILD
+++ b/community/ruby-rspec-core/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rspec-core
_gemname=${pkgname#ruby-}
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="RSpec runner and formatters"
url="https://relishapp.com/rspec/rspec-core/"
arch="noarch"
@@ -20,7 +20,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-rspec-expectations/APKBUILD b/community/ruby-rspec-expectations/APKBUILD
index b46c04ab8d..ef1e322c73 100644
--- a/community/ruby-rspec-expectations/APKBUILD
+++ b/community/ruby-rspec-expectations/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rspec-expectations
_gemname=${pkgname#ruby-}
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Provides a readable API to express expected outcomes of a code example in RSpec"
url="https://relishapp.com/rspec/rspec-expectations/"
arch="noarch"
@@ -20,7 +20,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-rspec-mocks/APKBUILD b/community/ruby-rspec-mocks/APKBUILD
index a96924f9af..fb4db6e8b6 100644
--- a/community/ruby-rspec-mocks/APKBUILD
+++ b/community/ruby-rspec-mocks/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rspec-mocks
_gemname=${pkgname#ruby-}
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="RSpec's 'test double' framework, with support for stubbing and mocking"
url="https://relishapp.com/rspec/rspec-mocks/"
arch="noarch"
@@ -20,7 +20,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-rspec-support/APKBUILD b/community/ruby-rspec-support/APKBUILD
index 327542cd66..cdc5e6c07f 100644
--- a/community/ruby-rspec-support/APKBUILD
+++ b/community/ruby-rspec-support/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rspec-support
_gemname=${pkgname#ruby-}
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Support utilities for RSpec gems"
url="https://relishapp.com/rspec/rspec-support/"
arch="noarch"
@@ -20,7 +20,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-rspec/APKBUILD b/community/ruby-rspec/APKBUILD
index ef343fbfe8..9a219d1b54 100644
--- a/community/ruby-rspec/APKBUILD
+++ b/community/ruby-rspec/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rspec
_gemname=${pkgname#ruby-}
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Behaviour Driven Development for Ruby"
url="http://rspec.info/"
arch="noarch"
@@ -23,7 +23,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \
diff --git a/community/ruby-timecop/APKBUILD b/community/ruby-timecop/APKBUILD
index 53a08c0efe..f5975745df 100644
--- a/community/ruby-timecop/APKBUILD
+++ b/community/ruby-timecop/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-timecop
_gemname=${pkgname#ruby-}
pkgver=0.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="A gem providing 'time travel' and 'time freezing' capabilities"
url="https://github.com/travisjeffery/timecop"
arch="noarch"
@@ -19,7 +19,7 @@ build() {
}
package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+ local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
cd "$builddir"
gem install --local \