aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-ansicolors/APKBUILD (renamed from testing/py-ansicolors/APKBUILD)16
-rw-r--r--testing/py3-ansicolors/fix-requires.patch11
2 files changed, 21 insertions, 6 deletions
diff --git a/testing/py-ansicolors/APKBUILD b/testing/py3-ansicolors/APKBUILD
index 18f839310e..b8d9551f24 100644
--- a/testing/py-ansicolors/APKBUILD
+++ b/testing/py3-ansicolors/APKBUILD
@@ -8,19 +8,23 @@ pkgdesc="ANSI colors for Python"
url="https://github.com/jonathaneunice/colors"
arch="noarch"
license="ISC"
-depends="python2"
-makedepends="python2-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+provides="py-ansicolors" # for backwards compatibility
+replaces="py-ansicolors=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
+ fix-requires.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="5afc4a7a6dc4028ad3db80c0e25e340482295ba41082107287abe7f20f6d4a2d0d17bccf269d7ac71482b7944134487f9238bb2c22c8a2f0bf9ea8288e543378 ansicolors-1.1.8.zip"
+sha512sums="5afc4a7a6dc4028ad3db80c0e25e340482295ba41082107287abe7f20f6d4a2d0d17bccf269d7ac71482b7944134487f9238bb2c22c8a2f0bf9ea8288e543378 ansicolors-1.1.8.zip
+4473c9a75c5d124e3e587cfb091d8f467bae0cbd23b6ab8295001f5bd91fe5381856b109e2be1a9f1197a5490a2dbd9f83e6e500c9364124b2e66c2826b16ae1 fix-requires.patch"
diff --git a/testing/py3-ansicolors/fix-requires.patch b/testing/py3-ansicolors/fix-requires.patch
new file mode 100644
index 0000000000..1b5fc8f30c
--- /dev/null
+++ b/testing/py3-ansicolors/fix-requires.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -18,7 +18,7 @@
+ license='ISC',
+ packages=['colors'],
+ install_requires=[],
+- test_requore=['tox', 'pytest', 'coverage', 'pytest-cov'],
++ tests_require=['tox', 'pytest', 'coverage', 'pytest-cov'],
+ test_suite="test",
+ zip_safe=False,
+ keywords='ASNI color style console',